5320 C# Programming Manual: D:/5320/C# Directory Reference

5320 C# Programming Manual
C# Directory Reference

Files

file | JY5320AITask.cs
file | JY5320CITask.cs
file | JY5320COTask.cs
file | JY5320DITask.cs
file | JY5320DOTask.cs
Generated by doxygen 1.9.1


5320 C# Programming Manual: D:/5320/C#/JY5320AITask.cs File Reference

Classes | Namespaces | Enumerations
JY5320AITask.cs File Reference

Classes

class | JY5320.JY5320AITask
JY5320 Analog Input Task. More...
class | JY5320.AIChannel
AI Channel parameter class More...
class | JY5320.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr More...
class | JY5320.AIAnalogWindowComparator
AI Analog Window Comparatorr More...
class | JY5320.AIAnalogEdgeComparator
AI Analog Edge Comparator More...
class | JY5320.AISampleClock
Sample clock configuration class More...
class | JY5320.AIExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5320.AITrigger
AI Trigger class More...
class | JY5320.AIDigitalTrigger
AI Digital Trigger More...
class | JY5320.AIAnalogTrigger
AI Analog Trigger More...
class | JY5320.AIRecord
AI Record class More...
class | JY5320.AIAdvanced
AI Advance parameter More...
class | JY5320.DSMode
DS Mode Class Paraments More...
class | JY5320.AISync
Configure sync signal More...
class | JY5320.AISignalExport
AI Signal Export Class More...

Namespaces

namespace JY5320

Enumerations

enum class | JY5320.AIBandWidth { JY5320._25KHz = JY5320Import.JY5320_AI_BandWidth_25K , JY5320._220KHz = JY5320Import.JY5320_AI_BandWidth_220K }
AI BandWidth More...
enum class | JY5320.AITriggerType { JY5320.Immediate = JY5320Import.JY5320_TriggerType_Immediately , JY5320.Digital = JY5320Import.JY5320_TriggerType_Digital , JY5320.Analog = JY5320Import.JY5320_TriggerType_Analog , JY5320.Soft = JY5320Import.JY5320_TriggerType_Soft }
Trigger Type: Digital/Analog/Immediate More...
enum class | JY5320.AIDigitalTriggerEdge { JY5320.Rising = JY5320Import.JY5320_DigitalTriggerEdge_Rising , JY5320.Falling = JY5320Import.JY5320_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge More...
enum class | JY5320.AIAnalogTriggerEdge { JY5320.Rising , JY5320.Falling }
AI Analog Trigger Edge More...
enum class | JY5320.AIAnalogWindowCondition { JY5320.Entering , JY5320.Leaving }
AI Analog Window Trigger Condition More...
enum class | JY5320.AIAnalogTriggerComparator { JY5320.Edge , JY5320.Hysteresis , JY5320.Window }
AI Analog Trigger Comparator More...
enum class | JY5320.AIMode { JY5320.Single = JY5320Import.JY5320_AI_Single , JY5320.Finite = JY5320Import.JY5320_AI_Finite , JY5320.Continuous = JY5320Import.JY5320_AI_Continuous , JY5320.Record = 0x3 }
AIMode More...
enum class | JY5320.AISampleClockSource { JY5320.Internal = JY5320Import.JY5320_AI_InternalClock , JY5320.External = JY5320Import.JY5320_AI_ExternalClock }
AIClockSource Type More...
enum class JY5320.ClockTerminal {
JY5320.PFI0 = JY5320Import.JY5320_DigitalTriggerSource_PFI_0 , JY5320.PFI1 = JY5320Import.JY5320_DigitalTriggerSource_PFI_1 , JY5320.PFI2 = JY5320Import.JY5320_DigitalTriggerSource_PFI_2 , JY5320.PFI3 = JY5320Import.JY5320_DigitalTriggerSource_PFI_3 ,
JY5320.PFI4 = JY5320Import.JY5320_DigitalTriggerSource_PFI_4 , JY5320.PFI5 = JY5320Import.JY5320_DigitalTriggerSource_PFI_5 , JY5320.PFI6 = JY5320Import.JY5320_DigitalTriggerSource_PFI_6 , JY5320.PFI7 = JY5320Import.JY5320_DigitalTriggerSource_PFI_7 ,
JY5320.PFI8 = JY5320Import.JY5320_DigitalTriggerSource_PFI_8 , JY5320.PFI9 = JY5320Import.JY5320_DigitalTriggerSource_PFI_9 , JY5320.PFI10 = JY5320Import.JY5320_DigitalTriggerSource_PFI_10 , JY5320.PFI11 = JY5320Import.JY5320_DigitalTriggerSource_PFI_11 ,
JY5320.PFI12 = JY5320Import.JY5320_DigitalTriggerSource_PFI_12 , JY5320.PFI13 = JY5320Import.JY5320_DigitalTriggerSource_PFI_13 , JY5320.PFI14 = JY5320Import.JY5320_DigitalTriggerSource_PFI_14 , JY5320.PFI15 = JY5320Import.JY5320_DigitalTriggerSource_PFI_15 ,
JY5320.PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , JY5320.PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , JY5320.PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 , JY5320.PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 ,
JY5320.PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , JY5320.PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , JY5320.PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 , JY5320.PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7 ,
JY5320.AI_SampleClock = JY5320Import.JY5320_AI_SampleClock , JY5320.CI0_SampleClock = JY5320Import.JY5320_CI0_SampleClock , JY5320.CI1_SampleClock = JY5320Import.JY5320_CI1_SampleClock , JY5320.CO0_Output = JY5320Import.JY5320_CO_0_Output ,
JY5320.CO1_Output = JY5320Import.JY5320_CO_1_Output
}
External Sample Clock Terminal More...
enum class | JY5320.AITriggerMode { JY5320.Start , JY5320.Reference }
AI Trigger Mode More...
enum class JY5320.AIAnalogTriggerSource {
JY5320.Channel_0 , JY5320.Channel_1 , JY5320.Channel_2 , JY5320.Channel_3 ,
JY5320.Channel_4 , JY5320.Channel_5 , JY5320.Channel_6 , JY5320.Channel_7 ,
JY5320.Channel_8 , JY5320.Channel_9 , JY5320.Channel_10 , JY5320.Channel_11 ,
JY5320.Channel_12 , JY5320.Channel_13 , JY5320.Channel_14 , JY5320.Channel_15 ,
JY5320.Channel_16 , JY5320.Channel_17 , JY5320.Channel_18 , JY5320.Channel_19 ,
JY5320.Channel_20 , JY5320.Channel_21 , JY5320.Channel_22 , JY5320.Channel_23 ,
JY5320.Channel_24 , JY5320.Channel_25 , JY5320.Channel_26 , JY5320.Channel_27 ,
JY5320.Channel_28 , JY5320.Channel_29 , JY5320.Channel_30 , JY5320.Channel_31
}
AI Analog Trigger Source More...
enum class JY5320.AIDigitalTriggerSource {
JY5320.PFI0 = JY5320Import.JY5320_DigitalTriggerSource_PFI_0 , JY5320.PFI1 = JY5320Import.JY5320_DigitalTriggerSource_PFI_1 , JY5320.PFI2 = JY5320Import.JY5320_DigitalTriggerSource_PFI_2 , JY5320.PFI3 = JY5320Import.JY5320_DigitalTriggerSource_PFI_3 ,
JY5320.PFI4 = JY5320Import.JY5320_DigitalTriggerSource_PFI_4 , JY5320.PFI5 = JY5320Import.JY5320_DigitalTriggerSource_PFI_5 , JY5320.PFI6 = JY5320Import.JY5320_DigitalTriggerSource_PFI_6 , JY5320.PFI7 = JY5320Import.JY5320_DigitalTriggerSource_PFI_7 ,
JY5320.PFI8 = JY5320Import.JY5320_DigitalTriggerSource_PFI_8 , JY5320.PFI9 = JY5320Import.JY5320_DigitalTriggerSource_PFI_9 , JY5320.PFI10 = JY5320Import.JY5320_DigitalTriggerSource_PFI_10 , JY5320.PFI11 = JY5320Import.JY5320_DigitalTriggerSource_PFI_11 ,
JY5320.PFI12 = JY5320Import.JY5320_DigitalTriggerSource_PFI_12 , JY5320.PFI13 = JY5320Import.JY5320_DigitalTriggerSource_PFI_13 , JY5320.PFI14 = JY5320Import.JY5320_DigitalTriggerSource_PFI_14 , JY5320.PFI15 = JY5320Import.JY5320_DigitalTriggerSource_PFI_15 ,
JY5320.PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , JY5320.PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , JY5320.PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 , JY5320.PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 ,
JY5320.PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , JY5320.PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , JY5320.PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 , JY5320.PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7 ,
JY5320.CI_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , JY5320.CI_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig , JY5320.CO_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , JY5320.CO_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig ,
JY5320.CI_0_OutPut = JY5320Import.JY5320_CO_0_Output , JY5320.CI_1_OutPut = JY5320Import.JY5320_CO_1_Output
}
AI Digital Trigger Source More...
enum class | JY5320.FileFormat { JY5320.Bin }
Streaming file format More...
enum class | JY5320.RecordMode { JY5320.Finite , JY5320.Infinite }
Two stream mode from enum Finite/Infinite More...
enum class | JY5320.SyncTopology { JY5320.Independent , JY5320.Master , JY5320.Slave }
Synchronization board configuration More...
enum class JY5320.SyncTriggerRouting {
JY5320.NONE = -1 , JY5320.PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , JY5320.PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , JY5320.PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 ,
JY5320.PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 , JY5320.PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , JY5320.PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , JY5320.PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 ,
JY5320.PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7
}
Master card trigger signal routing (Master card routes trigger signal to this port) More...
enum class JY5320.SyncPulseRouting {
JY5320.NONE = -1 , JY5320.PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , JY5320.PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , JY5320.PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 ,
JY5320.PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 , JY5320.PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , JY5320.PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , JY5320.PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 ,
JY5320.PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) More...
enum class | JY5320.AISignalExportSource { JY5320.StartTrig = 4 , JY5320.ReferenceTrig = 6 , JY5320.SampleClock = 1 }
AI Signal Export Source More...
enum class JY5320.SignalExportDestination {
JY5320.PFI0 = 8 , JY5320.PFI1 = 9 , JY5320.PFI2 = 10 , JY5320.PFI3 = 11 ,
JY5320.PFI4 = 12 , JY5320.PFI5 = 13 , JY5320.PFI6 = 14 , JY5320.PFI7 = 15 ,
JY5320.PFI8 = 16 , JY5320.PFI9 = 17 , JY5320.PFI10 = 18 , JY5320.PFI11 = 19 ,
JY5320.PFI12 = 20 , JY5320.PFI13 = 21 , JY5320.PFI14 = 22 , JY5320.PFI15 = 23 ,
JY5320.PXI_Trig0 = 0 , JY5320.PXI_Trig1 = 1 , JY5320.PXI_Trig2 = 2 , JY5320.PXI_Trig3 = 3 ,
JY5320.PXI_Trig4 = 4 , JY5320.PXI_Trig5 = 5 , JY5320.PXI_Trig6 = 6 , JY5320.PXI_Trig7 = 7
}
Output DestinationTerminal More...


5320 C# Programming Manual: JY5320.JY5320AITask Class Reference

  • JY5320
  • JY5320AITask
Public Member Functions | Properties | List of all members
JY5320.JY5320AITask Class Reference

JY5320 Analog Input Task. More...

Public Member Functions

JY5320AITask (int slotNumber)
Constructor. More...
JY5320AITask (string boardName)
Constructor. More...
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AIBandWidth bandWidth=AIBandWidth._25KHz)
Add one channel More...
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10, AIBandWidth bandWidth=AIBandWidth._25KHz)
Add a group of channels. More...
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh, AIBandWidth[] bandWidth)
Add a group of channels, each channel range can be set differently More...
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number. More...
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data. More...
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel data by columns and store it in a data buffer. More...
void | ReadData (ref double[,] buf, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data. More...
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel data and store it in a data buffer. More...
void | ReadData (ref double[] buf, int timeout=10000)
Read the one channel data and store it in a data buffer. More...
void | ReadRawData (ref short[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5320、PXIe/PCIe/USB-5310 More...
void | ReadRawData (ref short[,] buf, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5320、PXIe/PCIe/USB-5310 More...
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel raw data by columns and store it in a data buffer. More...
void | ReadRawData (ref short[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel raw data and store it in a data buffer. More...
void | ReadRawData (ref short[] buf, int timeout=10000)
Read the one channel raw data and store it in a data buffer. More...
void | ReadRawData (ref int[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321B、PXIe/PCIe/USB-5311B More...
void | ReadRawData (ref int[,] buf, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321B、PXIe/PCIe/USB-5311B More...
void | ReadRawData (ref int[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel raw data and store it in a data buffer. More...
void | ReadRawData (ref int[] buf, int timeout=10000)
Read the one channel raw data and store it in a data buffer. More...
void | ReadSinglePoint (ref double readValue, int channel)
Read one sample for specified channel in register. More...
void | ReadSinglePoint (ref double[] readValues)
Read raw one sample for all channels in register . More...
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout=1000)
Preview multi-channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[,] buf, int timeout=1000)
Preview multi-channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[] buf, int timeout=1000)
Preview one channel data when streaming is in progress. More...
void | GetRecordStatus (out double recordedLength, out bool recordDone)
Get the streaming status More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete More...
void | Start ()
Start AITask More...
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal More...
void | Stop ()
Stop AI Task More...

Properties

JY5320Device | Device [get]
Device Handle More...
List< AIChannel > | Channels [get, set]
List of AI channels,support 32 or 16 Different More...
AIMode | Mode [get, set]
AI acquisition mode，support Finite/Continuous/Record More...
double | SampleRate [get, set]
Sample rate per channel. More...
int | SamplesToAcquire [get, set]
Number of samples to be read per channel. More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value. More...
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration More...
AITrigger | Trigger [get, set]
时钟沿。仅在外部时钟时有效。 More...
AIRecord | Record [get]
Data streaming Configuration More...
bool | DisableCalibration [get, set]
Disalble calibration More...
AISync | Sync [get]
Multi card synchronous configuration More...
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration More...
AIAdvanced | Advanced [get, set]
AI Advanced Configuration More...

Detailed Description

JY5320 Analog Input Task.

Constructor & Destructor Documentation

◆ JY5320AITask() [1/2]

JY5320.JY5320AITask.JY5320AITask ( int slotNumber )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNumber Card slot number.

◆ JY5320AITask() [2/2]

JY5320.JY5320AITask.JY5320AITask ( string boardName )

Constructor.

Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JY5320.JY5320AITask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AIBandWidth | bandWidth = AIBandWidth._25KHz
 | ) |  |

Add one channel

Parameters
chnId | channel's physical number ，chnId=-1, add all channels,if 5321 5320 channel is 0 - 31. if 5311 5310 channel is 0 -15
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V, -0.5V, -0.25V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2V，1V, 0.5V, 0.25V,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ AddChannel() [2/3]

void JY5320.JY5320AITask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AIBandWidth | bandWidth = AIBandWidth._25KHz
 | ) |  |

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers,if 5321 5320 channel is 0 - 31. if 5311 5310 channel is 0 -15
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V, -0.5V, -0.25V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2V，1V, 0.5V, 0.25V,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ AddChannel() [3/3]

void JY5320.JY5320AITask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AIBandWidth[] | bandWidth
 | ) |  |

Add a group of channels, each channel range can be set differently

Parameters
chnsId | a group of channel physical numbers,,if 5321 5320 channel is 0 - 31. if 5311 5310 channel is 0 -15
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V, -0.5V, -0.25V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2V，1V, 0.5V, 0.25V,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ GetRecordPreviewData() [1/4]

void JY5320.JY5320AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000
 | ) |  |

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [2/4]

void JY5320.JY5320AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = 1000
 | ) |  |

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms
Returns

◆ GetRecordPreviewData() [3/4]

void JY5320.JY5320AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000
 | ) |  |

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [4/4]

void JY5320.JY5320AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = 1000
 | ) |  |

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY5320.JY5320AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone
 | ) |  |

Get the streaming status

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ ReadData() [1/5]

void JY5320.JY5320AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [2/5]

void JY5320.JY5320AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [3/5]

void JY5320.JY5320AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
timeout timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [4/5]

void JY5320.JY5320AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadData() [5/5]

void JY5320.JY5320AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [1/9]

void JY5320.JY5320AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr. PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5320、PXIe/PCIe/USB-5310 Data Type is short PXIe/PCIe/USB-5321B、PXIe/PCIe/USB-5311B Data Type is int

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [2/9]

void JY5320.JY5320AITask.ReadRawData | ( | ref int | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321B、PXIe/PCIe/USB-5311B

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [3/9]

void JY5320.JY5320AITask.ReadRawData | ( | ref int | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321B、PXIe/PCIe/USB-5311B

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [4/9]

void JY5320.JY5320AITask.ReadRawData | ( | ref int[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel raw data and store it in a data buffer.

Support Device: PXIe/PCIe/USB-5321B、PXIe/PCIe/USB-5311B

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [5/9]

void JY5320.JY5320AITask.ReadRawData | ( | ref int[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel raw data and store it in a data buffer.

Support Device: PXIe/PCIe/USB-5321B、PXIe/PCIe/USB-5311B

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [6/9]

void JY5320.JY5320AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5320、PXIe/PCIe/USB-5310

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [7/9]

void JY5320.JY5320AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5320、PXIe/PCIe/USB-5310

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [8/9]

void JY5320.JY5320AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel raw data and store it in a data buffer.

Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5320、PXIe/PCIe/USB-5310

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [9/9]

void JY5320.JY5320AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel raw data and store it in a data buffer.

Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5320、PXIe/PCIe/USB-5310

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadSinglePoint() [1/2]

void JY5320.JY5320AITask.ReadSinglePoint | ( | ref double | readValue,
 |  | int | channel
 | ) |  |

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY5320.JY5320AITask.ReadSinglePoint ( ref double[] readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JY5320.JY5320AITask.RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY5320.JY5320AITask.SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal

Returns

◆ Start()

void JY5320.JY5320AITask.Start ( )

Start AITask

◆ Stop()

void JY5320.JY5320AITask.Stop ( )

Stop AI Task

◆ WaitUntilDone()

bool JY5320.JY5320AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate
Returns
True: task end, false: timeout

Property Documentation

◆ Advanced

AIAdvanced JY5320.JY5320AITask.Advanced
getset

AI Advanced Configuration

◆ AvailableSamples

ulong JY5320.JY5320AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer

◆ BufLenInSamples

int JY5320.JY5320AITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JY5320.JY5320AITask.Channels
getset

List of AI channels,support 32 or 16 Different

◆ Device

JY5320Device JY5320.JY5320AITask.Device
get

Device Handle

◆ DisableCalibration

bool JY5320.JY5320AITask.DisableCalibration
getset

Disalble calibration

◆ Mode

AIMode JY5320.JY5320AITask.Mode
getset

AI acquisition mode，support Finite/Continuous/Record

◆ Record

AIRecord JY5320.JY5320AITask.Record
get

Data streaming Configuration

◆ SampleClock

AISampleClock JY5320.JY5320AITask.SampleClock
getset

AI Sample Clock Configuration

◆ SampleRate

double JY5320.JY5320AITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 1M for 5321 5311，Maximum sample rate is 200K for 5320 5310 The defalut sample rate = 100k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5320.JY5320AITask.SamplesToAcquire
getset

Number of samples to be read per channel.

default: 1000. Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JY5320.JY5320AITask.SignalExport
getset

Export AI Signal Configuration

◆ Sync

AISync JY5320.JY5320AITask.Sync
get

Multi card synchronous configuration

◆ TransferedSamples

ulong JY5320.JY5320AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

◆ Trigger

AITrigger JY5320.JY5320AITask.Trigger
getset

时钟沿。仅在外部时钟时有效。

AI Trigger Configuration

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AIChannel Class Reference

  • AIChannel
Public Member Functions | Properties | List of all members
JY5320.AIChannel Class Reference

AI Channel parameter class More...

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AIBandWidth bandWidth)
Constructor to create an AIChnParam task object. More...

Properties

int | ChannelID [get]
AI channel ID. More...
double | RangeLow [get, set]
Low range limit an AI channel，-10V,-5V,-2.5V，-1V, -0.5V, -0.25V More...
double | RangeHigh [get, set]
High range limit an AI channel，10V,5V,2.5V，1V, 0.5V, 0.25V More...
AIBandWidth | BandWidth [get, set]
AI BandWidth,default 50KHz. More...

Detailed Description

AI Channel parameter class

Constructor & Destructor Documentation

◆ AIChannel()

JY5320.AIChannel.AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AIBandWidth | bandWidth
 | ) |  |

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.
bandWidth | AI BandWidth.

Property Documentation

◆ BandWidth

AIBandWidth JY5320.AIChannel.BandWidth
getset

AI BandWidth,default 50KHz.

◆ ChannelID

int JY5320.AIChannel.ChannelID
get

AI channel ID.

◆ RangeHigh

double JY5320.AIChannel.RangeHigh
getset

High range limit an AI channel，10V,5V,2.5V，1V, 0.5V, 0.25V

◆ RangeLow

double JY5320.AIChannel.RangeLow
getset

Low range limit an AI channel，-10V,-5V,-2.5V，-1V, -0.5V, -0.25V

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JY5320.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr More...

Public Attributes

double | HighThreshold
High Threshold More...
double | LowThreshold
Low Threshold More...

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge More...

Detailed Description

AI Analog Hysteresis Comparatorr

Member Data Documentation

◆ HighThreshold

double JY5320.AIAnalogHysteresisComparator.HighThreshold

High Threshold

◆ LowThreshold

double JY5320.AIAnalogHysteresisComparator.LowThreshold

Low Threshold

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5320.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JY5320.AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr More...

Public Attributes

double | HighThreshold
High Threshold More...
double | LowThreshold
Low Threshold More...

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition More...

Detailed Description

AI Analog Window Comparatorr

Member Data Documentation

◆ HighThreshold

double JY5320.AIAnalogWindowComparator.HighThreshold

High Threshold

◆ LowThreshold

double JY5320.AIAnalogWindowComparator.LowThreshold

Low Threshold

Property Documentation

◆ Condition

AIAnalogWindowCondition JY5320.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JY5320.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator More...

Public Attributes

double Threshold
Threshold More...

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge More...

Detailed Description

AI Analog Edge Comparator

Member Data Documentation

◆ Threshold

double JY5320.AIAnalogEdgeComparator.Threshold

Threshold

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5320.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JY5320.AISampleClock Class Reference

Sample clock configuration class More...

Properties

AISampleClockSource | Source [get, set]
Clock Source. More...
AIExternalSampleClock | External [get, set]
External Sample Clock， Valid when Source is AISampleClockSource.External. More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ External

AIExternalSampleClock JY5320.AISampleClock.External
getset

External Sample Clock， Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY5320.AISampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JY5320.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5320.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5320.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY5320.AITrigger Class Reference

AI Trigger class More...

Properties

AITriggerType | Type [get, set]
AI Trigger Type,enum Analog/Digital/Immediate/Soft. More...
AITriggerMode | Mode [get, set]
AI Trigger Mode. More...
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration. More...
AIAnalogTrigger | Analog [get, set]
AI Analog Trigger. More...
int | ReTriggerCount [get, set]
Number of repeat triggers. More...
uint | PreTriggerSamples [get, set]
AI pretrigger samples, must be less than or equal to JY5320AITask.SamplesToAcquire. More...

Detailed Description

AI Trigger class

Property Documentation

◆ Analog

AIAnalogTrigger JY5320.AITrigger.Analog
getset

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger JY5320.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5320.AITrigger.Mode
getset

AI Trigger Mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

uint JY5320.AITrigger.PreTriggerSamples
getset

AI pretrigger samples, must be less than or equal to JY5320AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference.

◆ ReTriggerCount

int JY5320.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5320.AITrigger.Type
getset

AI Trigger Type,enum Analog/Digital/Immediate/Soft.

The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY5320.AIDigitalTrigger Class Reference

AI Digital Trigger More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI Digital Trigger Source More...
AIDigitalTriggerEdge | Edge [get, set]
AI Digital Trigger Edge，Rising/Falling More...

Detailed Description

AI Digital Trigger

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY5320.AIDigitalTrigger.Edge
getset

AI Digital Trigger Edge，Rising/Falling

◆ Source

AIDigitalTriggerSource JY5320.AIDigitalTrigger.Source
getset

AI Digital Trigger Source

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JY5320.AIAnalogTrigger Class Reference

AI Analog Trigger More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source More...
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator More...
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator More...
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr More...
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr More...

Detailed Description

AI Analog Trigger

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY5320.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator

◆ Edge

AIAnalogEdgeComparator JY5320.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator

◆ Hysteresis

AIAnalogHysteresisComparator JY5320.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr

◆ Source

AIAnalogTriggerSource JY5320.AIAnalogTrigger.Source
getset

Analog Trigger source

◆ Window

AIAnalogWindowComparator JY5320.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JY5320.AIRecord Class Reference

AI Record class More...

Properties

string | FilePath [get, set]
Path of streaming file,including filePath and filename More...
FileFormat | FileFormat [get]
Streaming file format More...
RecordMode | Mode [get, set]
Two stream mode from enum Finite/Infinite More...
double | Length [get, set]
User specified stream length in second. More...

Detailed Description

AI Record class

Property Documentation

◆ FileFormat

FileFormat JY5320.AIRecord.FileFormat
get

Streaming file format

◆ FilePath

string JY5320.AIRecord.FilePath
getset

Path of streaming file,including filePath and filename

◆ Length

double JY5320.AIRecord.Length
getset

User specified stream length in second.

Only valid in the Finite mode

◆ Mode

RecordMode JY5320.AIRecord.Mode
getset

Two stream mode from enum Finite/Infinite

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AIAdvanced Class Reference

  • AIAdvanced
Properties | List of all members
JY5320.AIAdvanced Class Reference

AI Advance parameter More...

Properties

DSMode DSMode [get, set]
DSMode Config More...

Detailed Description

AI Advance parameter

Property Documentation

◆ DSMode

DSMode JY5320.AIAdvanced.DSMode
getset

DSMode Config

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.DSMode Class Reference

  • DSMode
Properties | List of all members
JY5320.DSMode Class Reference

DS Mode Class Paraments More...

Properties

bool Enable [get, set]
Enable DSMode More...

Detailed Description

DS Mode Class Paraments

Property Documentation

◆ Enable

bool JY5320.DSMode.Enable
getset

Enable DSMode

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AISync Class Reference

  • AISync
Properties | List of all members
JY5320.AISync Class Reference

Configure sync signal More...

Properties

SyncTopology | Topology [get, set]
Configure sync signal More...
SyncTriggerRouting | TriggerRouting [get, set]
trigger signal Routing, default routing PXITrig0 More...
SyncPulseRouting | PulseRouting [get, set]
Sync Pulse signal Routing, default routing PXITrig1 More...

Detailed Description

Configure sync signal

Property Documentation

◆ PulseRouting

SyncPulseRouting JY5320.AISync.PulseRouting
getset

Sync Pulse signal Routing, default routing PXITrig1

◆ Topology

SyncTopology JY5320.AISync.Topology
getset

Configure sync signal

◆ TriggerRouting

SyncTriggerRouting JY5320.AISync.TriggerRouting
getset

trigger signal Routing, default routing PXITrig0

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: JY5320.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5320.AISignalExport Class Reference

AI Signal Export Class More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

AI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5320.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5320.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY5320.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5320.AISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320AITask.cs


5320 C# Programming Manual: D:/5320/C#/JY5320CITask.cs File Reference

Classes | Namespaces | Enumerations
JY5320CITask.cs File Reference

Classes

class | JY5320.JY5320CITask
JY5320 Counter Input Task More...
class | JY5320.CISampleClock
CI Sample Clock class More...
class | JY5320.CIInternalSampleClock
CI Internal Sample Clock Configuration Class More...
class | JY5320.CIImplicitSampleClock
CI Implicit Sample Clock class More...
class | JY5320.CIExternalSampleClock
CI Implicit Sample Clock class More...
class | JY5320.CIExternalTimebase
class | JY5320.CITimebase
class | JY5320.EdgeCounting
Configure CI EdgeCounting. More...
class | JY5320.EdgeCountingOutEvent
Edge counting output event configuration class More...
class | JY5320.PauseTrigger
Pause trigger configuration class. More...
class | JY5320.FrequencyMeas
Configure CI Measure. More...
class | JY5320.PeriodMeas
Configure CI Measure. More...
class | JY5320.PulseMeas
Configure CI Measure. More...
class | JY5320.SemiPeriodMeas
Configure CI Measure. More...
class | JY5320.TwoEdgeSeparation
Configure CI Measure. More...
class | JY5320.QuadEncoder
Configure CI Measure. More...
class | JY5320.TwoPulseEncoder
Configure CI Measure. More...
class | JY5320.CITrigger
Constructor to create an CITrigger task object. More...
class | JY5320.CIDigitalTrigger
CI Digital trigger . More...
class | JY5320.CISignalExport
CI Signal Export Class More...

Namespaces

namespace JY5320

Enumerations

enum class | JY5320.CountDirection { JY5320.Up = JY5320Import.JY5320_CI_Count_Up , JY5320.Down = JY5320Import.JY5320_CI_Count_Down , JY5320.External = JY5320Import.JY5320_CI_Count_External }
Counter direction. More...
enum class | JY5320.CIMode { JY5320.Single = 2 , JY5320.Finite = 0 , JY5320.Continuous = 1 }
CIMode More...
enum class JY5320.CIType {
JY5320.EdgeCounting , JY5320.Period , JY5320.Frequency , JY5320.Pulse ,
JY5320.SemiPeriod , JY5320.TwoEdgeSeparation , JY5320.QuadEncoder , JY5320.TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | JY5320.CISampleClockSource { JY5320.Implicit = JY5320Import.JY5320_CI_ImplicitClock , JY5320.Internal = JY5320Import.JY5320_CI_InternalClock , JY5320.External = JY5320Import.JY5320_CI_ExternalClock }
CI Sample Clock Source. More...
enum class | JY5320.EdgeType { JY5320.Rising , JY5320.Falling , JY5320.Any }
Edge Type More...
enum class | JY5320.CITimebaseSource { JY5320.Internal100MHz = 0 , JY5320.Internal5MHz = 1 , JY5320.Internal100kHz = 2 , JY5320.External = 3 }
enum class | JY5320.EdgeCntOunEvtIdleState { JY5320.LowLevel = 0 , JY5320.HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | JY5320.LevelPolarity { JY5320.LowLevel = 0 , JY5320.HighLevel = 1 , JY5320.None = 2 }
Level Polarity More...
enum class | JY5320.QuadEncodingType { JY5320.X1 , JY5320.X2 , JY5320.X4 }
Quadrature Encoding Type More...
enum class | JY5320.CITriggerType { JY5320.Immediate = JY5320Import.JY5320_CIO_Immediately , JY5320.Digital = JY5320Import.JY5320_CIO_Digital , JY5320.Soft = JY5320Import.JY5320_CIO_Soft }
TriggerType Digital/Immediate/Soft More...
enum class JY5320.CIDigitalTriggerSource {
JY5320.PFI0 = JY5320Import.JY5320_DigitalTriggerSource_PFI_0 , JY5320.PFI1 = JY5320Import.JY5320_DigitalTriggerSource_PFI_1 , JY5320.PFI2 = JY5320Import.JY5320_DigitalTriggerSource_PFI_2 , JY5320.PFI3 = JY5320Import.JY5320_DigitalTriggerSource_PFI_3 ,
JY5320.PFI4 = JY5320Import.JY5320_DigitalTriggerSource_PFI_4 , JY5320.PFI5 = JY5320Import.JY5320_DigitalTriggerSource_PFI_5 , JY5320.PFI6 = JY5320Import.JY5320_DigitalTriggerSource_PFI_6 , JY5320.PFI7 = JY5320Import.JY5320_DigitalTriggerSource_PFI_7 ,
JY5320.PFI8 = JY5320Import.JY5320_DigitalTriggerSource_PFI_8 , JY5320.PFI9 = JY5320Import.JY5320_DigitalTriggerSource_PFI_9 , JY5320.PFI10 = JY5320Import.JY5320_DigitalTriggerSource_PFI_10 , JY5320.PFI11 = JY5320Import.JY5320_DigitalTriggerSource_PFI_11 ,
JY5320.PFI12 = JY5320Import.JY5320_DigitalTriggerSource_PFI_12 , JY5320.PFI13 = JY5320Import.JY5320_DigitalTriggerSource_PFI_13 , JY5320.PFI14 = JY5320Import.JY5320_DigitalTriggerSource_PFI_14 , JY5320.PFI15 = JY5320Import.JY5320_DigitalTriggerSource_PFI_15 ,
JY5320.PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , JY5320.PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , JY5320.PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 , JY5320.PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 ,
JY5320.PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , JY5320.PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , JY5320.PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 , JY5320.PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7 ,
JY5320.AI_StartTrig = JY5320Import.JY5320_AI_StartTrig , JY5320.AI_ReferenceTrig = JY5320Import.JY5320_AI_ReferenceTrig , JY5320.CI_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , JY5320.CI_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig ,
JY5320.CO_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , JY5320.CO_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig , JY5320.CI_0_OutPut = JY5320Import.JY5320_CO_0_Output , JY5320.CI_1_OutPut = JY5320Import.JY5320_CO_1_Output
}
CI Digital trigger source. More...
enum class | JY5320.CIDigitalTriggerEdge { JY5320.Rising , JY5320.Falling }
CI Digital Trigger Edge More...
enum class JY5320.InputTerminal {
JY5320.PFI0 = JY5320Import.JY5320_DigitalTriggerSource_PFI_0 , JY5320.PFI1 = JY5320Import.JY5320_DigitalTriggerSource_PFI_1 , JY5320.PFI2 = JY5320Import.JY5320_DigitalTriggerSource_PFI_2 , JY5320.PFI3 = JY5320Import.JY5320_DigitalTriggerSource_PFI_3 ,
JY5320.PFI4 = JY5320Import.JY5320_DigitalTriggerSource_PFI_4 , JY5320.PFI5 = JY5320Import.JY5320_DigitalTriggerSource_PFI_5 , JY5320.PFI6 = JY5320Import.JY5320_DigitalTriggerSource_PFI_6 , JY5320.PFI7 = JY5320Import.JY5320_DigitalTriggerSource_PFI_7 ,
JY5320.PFI8 = JY5320Import.JY5320_DigitalTriggerSource_PFI_8 , JY5320.PFI9 = JY5320Import.JY5320_DigitalTriggerSource_PFI_9 , JY5320.PFI10 = JY5320Import.JY5320_DigitalTriggerSource_PFI_10 , JY5320.PFI11 = JY5320Import.JY5320_DigitalTriggerSource_PFI_11 ,
JY5320.PFI12 = JY5320Import.JY5320_DigitalTriggerSource_PFI_12 , JY5320.PFI13 = JY5320Import.JY5320_DigitalTriggerSource_PFI_13 , JY5320.PFI14 = JY5320Import.JY5320_DigitalTriggerSource_PFI_14 , JY5320.PFI15 = JY5320Import.JY5320_DigitalTriggerSource_PFI_15 ,
JY5320.PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , JY5320.PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , JY5320.PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 , JY5320.PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 ,
JY5320.PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , JY5320.PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , JY5320.PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 , JY5320.PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7 ,
JY5320.CI_0_OutPut = JY5320Import.JY5320_CO_0_Output , JY5320.CI_1_OutPut = JY5320Import.JY5320_CO_1_Output , JY5320.Timebase_100MHz = JY5320Import.JY5320_CIO_100MHz , JY5320.Timebase_5MHz = JY5320Import.JY5320_CIO_5MHz ,
JY5320.Timebase_100kHz = JY5320Import.JY5320_CIO_100kHz
}
enum class JY5320.IOTerminal {
JY5320.PFI0 = JY5320Import.JY5320_DigitalTriggerOut_PFI_0 , JY5320.PFI1 = JY5320Import.JY5320_DigitalTriggerOut_PFI_1 , JY5320.PFI2 = JY5320Import.JY5320_DigitalTriggerOut_PFI_2 , JY5320.PFI3 = JY5320Import.JY5320_DigitalTriggerOut_PFI_3 ,
JY5320.PFI4 = JY5320Import.JY5320_DigitalTriggerOut_PFI_4 , JY5320.PFI5 = JY5320Import.JY5320_DigitalTriggerOut_PFI_5 , JY5320.PFI6 = JY5320Import.JY5320_DigitalTriggerOut_PFI_6 , JY5320.PFI7 = JY5320Import.JY5320_DigitalTriggerOut_PFI_7 ,
JY5320.PFI8 = JY5320Import.JY5320_DigitalTriggerOut_PFI_8 , JY5320.PFI9 = JY5320Import.JY5320_DigitalTriggerOut_PFI_9 , JY5320.PFI10 = JY5320Import.JY5320_DigitalTriggerOut_PFI_10 , JY5320.PFI11 = JY5320Import.JY5320_DigitalTriggerOut_PFI_11 ,
JY5320.PFI12 = JY5320Import.JY5320_DigitalTriggerOut_PFI_12 , JY5320.PFI13 = JY5320Import.JY5320_DigitalTriggerOut_PFI_13 , JY5320.PFI14 = JY5320Import.JY5320_DigitalTriggerOut_PFI_14 , JY5320.PFI15 = JY5320Import.JY5320_DigitalTriggerOut_PFI_15 ,
JY5320.PXI_Trig0 = JY5320Import.JY5320_TriggerOut_PXI_0 , JY5320.PXI_Trig1 = JY5320Import.JY5320_TriggerOut_PXI_1 , JY5320.PXI_Trig2 = JY5320Import.JY5320_TriggerOut_PXI_2 , JY5320.PXI_Trig3 = JY5320Import.JY5320_TriggerOut_PXI_3 ,
JY5320.PXI_Trig4 = JY5320Import.JY5320_TriggerOut_PXI_4 , JY5320.PXI_Trig5 = JY5320Import.JY5320_TriggerOut_PXI_5 , JY5320.PXI_Trig6 = JY5320Import.JY5320_TriggerOut_PXI_6 , JY5320.PXI_Trig7 = JY5320Import.JY5320_TriggerOut_PXI_7
}
enum class | JY5320.CISignalExportSource { JY5320.StartTrig , JY5320.SampleClock }
SourceSignal More...


5320 C# Programming Manual: JY5320.JY5320CITask Class Reference

  • JY5320CITask
Public Member Functions | Properties | List of all members
JY5320.JY5320CITask Class Reference

JY5320 Counter Input Task More...

Public Member Functions

JY5320CITask (int slotNum, int channel)
Constructor. More...
JY5320CITask (string boardName, int channel)
Constructor. More...
void | Start ()
Start CI task . More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
void | Stop ()
Stop CI task . More...
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder More...
void | ReadData (ref uint[] bufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer. More...
void | ReadData (ref uint[] bufCount, int timeout=10000)
Read counter values from buffer. More...
void | ReadData (ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer. More...
void | ReadData (ref double[] bufMeasurement, int timeout=10000)
Read frequency value or period value from buffer. More...
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register. More...
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register. More...
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer. More...
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer. More...

Properties

CIType | Type [get, set]
CI Application types. More...
ulong | AvailableSamples [get]
Number of points per channel that can be read in the buffer . More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
CIMode | Mode [get, set]
CI Sampling mode，support Single/Finite/Continuous More...
CISampleClock | SampleClock [get, set]
Clock Source. More...
uint | SamplesToAcquire [get, set]
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite. More...
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration More...
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration More...
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration More...
SemiPeriodMeas | SemiPeriodMeas [get, set]
SemiPeriodMeas Measurement Configuration More...
PulseMeas | PulseMeas [get, set]
Pulse Measurement Configuration More...
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
TwoEdgeSeparation More...
QuadEncoder | QuadEncoder [get, set]
QuadEncoder More...
TwoPulseEncoder | TwoPulseEncoder [get, set]
TwoPulseEncoder More...
CITrigger | Trigger = new CITrigger() [get, set]
CI Trigger Configuration. More...
CISignalExport | SignalExport [get, set]
Export CI Signal Configuration More...
JY5320Device | Device [get]
Device More...

Detailed Description

JY5320 Counter Input Task

Constructor & Destructor Documentation

◆ JY5320CITask() [1/2]

JY5320.JY5320CITask.JY5320CITask | ( | int | slotNum,
 |  | int | channel
 | ) |  |

Constructor.

Used to create an CI task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1

◆ JY5320CITask() [2/2]

JY5320.JY5320CITask.JY5320CITask | ( | string | boardName,
 |  | int | channel
 | ) |  |

Constructor.

Used to create an CI task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1）.

Member Function Documentation

◆ ReadData() [1/6]

void JY5320.JY5320CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000
 | ) |  |

Read frequency value or period value from buffer.

Available when JY5320CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JY5320.JY5320CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | timeout = 10000
 | ) |  |

Read frequency value or period value from buffer.

Available when JY5320CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JY5320.JY5320CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000
 | ) |  |

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5320CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JY5320.JY5320CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | timeout = 10000
 | ) |  |

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5320CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JY5320.JY5320CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000
 | ) |  |

Read counter values from buffer.

Available when JY5320CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JY5320.JY5320CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | timeout = 10000
 | ) |  |

Read counter values from buffer.

Available when JY5320CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY5320.JY5320CITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000
 | ) |  |

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY5320.JY5320CITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000
 | ) |  |

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY5320.JY5320CITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY5320.JY5320CITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5320.JY5320CITask.Start ( )

Start CI task .

◆ Stop()

void JY5320.JY5320CITask.Stop ( )

Stop CI task .

Property Documentation

◆ AvailableSamples

ulong JY5320.JY5320CITask.AvailableSamples
get

Number of points per channel that can be read in the buffer .

◆ Device

JY5320Device JY5320.JY5320CITask.Device
get

Device

◆ EdgeCounting

EdgeCounting JY5320.JY5320CITask.EdgeCounting
getset

Edge Counting Configuration

◆ FrequencyMeas

FrequencyMeas JY5320.JY5320CITask.FrequencyMeas
getset

Frequency Measurement Configuration

◆ Mode

CIMode JY5320.JY5320CITask.Mode
getset

CI Sampling mode，support Single/Finite/Continuous

◆ PeriodMeas

PeriodMeas JY5320.JY5320CITask.PeriodMeas
getset

Period Measurement Configuration

◆ PulseMeas

PulseMeas JY5320.JY5320CITask.PulseMeas
getset

Pulse Measurement Configuration

◆ QuadEncoder

QuadEncoder JY5320.JY5320CITask.QuadEncoder
getset

QuadEncoder

◆ SampleClock

CISampleClock JY5320.JY5320CITask.SampleClock
getset

Clock Source.

◆ SamplesToAcquire

uint JY5320.JY5320CITask.SamplesToAcquire
getset

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

SemiPeriodMeas JY5320.JY5320CITask.SemiPeriodMeas
getset

SemiPeriodMeas Measurement Configuration

◆ SignalExport

CISignalExport JY5320.JY5320CITask.SignalExport
getset

Export CI Signal Configuration

◆ TransferedSamples

ulong JY5320.JY5320CITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger JY5320.JY5320CITask.Trigger = new CITrigger()
getset

CI Trigger Configuration.

◆ TwoEdgeSeparation

TwoEdgeSeparation JY5320.JY5320CITask.TwoEdgeSeparation
getset

TwoEdgeSeparation

◆ TwoPulseEncoder

TwoPulseEncoder JY5320.JY5320CITask.TwoPulseEncoder
getset

TwoPulseEncoder

◆ Type

CIType JY5320.JY5320CITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.CISampleClock Class Reference

  • CISampleClock
Properties | List of all members
JY5320.CISampleClock Class Reference

CI Sample Clock class More...

Properties

CISampleClockSource | Source [get, set]
CI Sample Clock Source More...
CIExternalSampleClock | External [get, set]
CI External Sample Clock Configuration. More...
CIImplicitSampleClock | Implicit [get, set]
CI Implicit Sample Clock Configuration. More...
CIInternalSampleClock | Internal [get]
Internal Sample Clock Configuration. More...

Detailed Description

CI Sample Clock class

Property Documentation

◆ External

CIExternalSampleClock JY5320.CISampleClock.External
getset

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock JY5320.CISampleClock.Implicit
getset

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock JY5320.CISampleClock.Internal
get

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY5320.CISampleClock.Source
getset

CI Sample Clock Source

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Properties | List of all members
JY5320.CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class More...

Properties

double | Rate [get, set]
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz). More...
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data More...

Detailed Description

CI Internal Sample Clock Configuration Class

Property Documentation

◆ IgnoreFirstSampleClock

bool JY5320.CIInternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data

◆ Rate

double JY5320.CIInternalSampleClock.Rate
getset

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Properties | List of all members
JY5320.CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class More...

Properties

double ExpectedRate [get, set]
Expected Rate of Implicit Sample Clock. More...

Detailed Description

CI Implicit Sample Clock class

Property Documentation

◆ ExpectedRate

double JY5320.CIImplicitSampleClock.ExpectedRate
getset

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Properties | List of all members
JY5320.CIExternalSampleClock Class Reference

CI Implicit Sample Clock class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected Rate of External Sample Clock. More...
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data More...

Detailed Description

CI Implicit Sample Clock class

Property Documentation

◆ ExpectedRate

double JY5320.CIExternalSampleClock.ExpectedRate
getset

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

bool JY5320.CIExternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data

◆ Terminal

ClockTerminal JY5320.CIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.CIExternalTimebase Class Reference

  • CIExternalTimebase
Properties | List of all members
JY5320.CIExternalTimebase Class Reference

More...

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5320.CIExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5320.CIExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.CITimebase Class Reference

  • CITimebase
Properties | List of all members
JY5320.CITimebase Class Reference

More...

Properties

CITimebaseSource | Source [get, set]
CIExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

CIExternalTimebase JY5320.CITimebase.External
getset

外部时基配置。当 CITimebase.Source 为 CITimebaseSource.External时有效。

External Timebase Configuration. Valid when CITimebase.Source is COTimebaseSource.External.

◆ Source

CITimebaseSource JY5320.CITimebase.Source
getset

时基源。默认值为 CITimebaseSource.Internal100MHz。

Timebase Source. The default value is CITimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JY5320.EdgeCounting Class Reference

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count More...
CountDirection | Direction [get, set]
Counter direction. More...
EdgeType | ActiveEdge [get, set]
The avtive edge of the input signal, the counter will count up or down on this edge. More...
PauseTrigger | Pause [get, set]
Pause Trigger Configuration More...
EdgeCountingOutEvent | OutEvent [get, set]
Edge counting output event. More...
InputTerminal | InputTerminal [get, set]
Input Terminal More...
InputTerminal | DirTerminal [get, set]
Terminal of External Count Diretion Control. More...

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ ActiveEdge

EdgeType JY5320.EdgeCounting.ActiveEdge
getset

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY5320.EdgeCounting.Direction
getset

Counter direction.

enum Up/Down/External

◆ DirTerminal

InputTerminal JY5320.EdgeCounting.DirTerminal
getset

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY5320.EdgeCounting.InitialCount
getset

Initial Count

◆ InputTerminal

InputTerminal JY5320.EdgeCounting.InputTerminal
getset

Input Terminal

◆ OutEvent

EdgeCountingOutEvent JY5320.EdgeCounting.OutEvent
getset

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger JY5320.EdgeCounting.Pause
getset

Pause Trigger Configuration

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Properties | List of all members
JY5320.EdgeCountingOutEvent Class Reference

Edge counting output event configuration class More...

Properties

EdgeCntOunEvtIdleState | IdleState [get, set]
Output idle state when the event has not occurred. More...
uint | Threshold [get, set]
Comparison threshold. More...
IOTerminal | Terminal [get, set]
Terminal More...

Detailed Description

Edge counting output event configuration class

Property Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY5320.EdgeCountingOutEvent.IdleState
getset

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JY5320.EdgeCountingOutEvent.Terminal
getset

Terminal

◆ Threshold

uint JY5320.EdgeCountingOutEvent.Threshold
getset

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JY5320.PauseTrigger Class Reference

Pause trigger configuration class. More...

Properties

LevelPolarity | ActivePolarity [get, set]
Pause trigger active polarity. More...
InputTerminal | Terminal [get, set]
Terminal More...

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JY5320.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY5320.PauseTrigger.Terminal
getset

Terminal

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.FrequencyMeas Class Reference

  • FrequencyMeas
Properties | List of all members
JY5320.FrequencyMeas Class Reference

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration More...
InputTerminal | InputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5320.FrequencyMeas.InputTerminal
getset

Input Terminal

◆ Timebase

CITimebase JY5320.FrequencyMeas.Timebase
getset

Timebase configuration

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.PeriodMeas Class Reference

  • PeriodMeas
Properties | List of all members
JY5320.PeriodMeas Class Reference

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration More...
InputTerminal | InputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5320.PeriodMeas.InputTerminal
getset

Input Terminal

◆ Timebase

CITimebase JY5320.PeriodMeas.Timebase
getset

Timebase configuration

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.PulseMeas Class Reference

  • PulseMeas
Properties | List of all members
JY5320.PulseMeas Class Reference

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration More...
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge. More...
InputTerminal | InputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5320.PulseMeas.InputTerminal
getset

Input Terminal

◆ StartingEdge

EdgeType JY5320.PulseMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5320.PulseMeas.Timebase
getset

Timebase configuration

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Properties | List of all members
JY5320.SemiPeriodMeas Class Reference

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration More...
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge. More...
InputTerminal | InputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5320.SemiPeriodMeas.InputTerminal
getset

Input Terminal

◆ StartingEdge

EdgeType JY5320.SemiPeriodMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5320.SemiPeriodMeas.Timebase
getset

Timebase configuration

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Properties | List of all members
JY5320.TwoEdgeSeparation Class Reference

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration More...
InputTerminal | FirstInputTerminal [get, set]
Input Terminal More...
InputTerminal | SecondInputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ FirstInputTerminal

InputTerminal JY5320.TwoEdgeSeparation.FirstInputTerminal
getset

Input Terminal

◆ SecondInputTerminal

InputTerminal JY5320.TwoEdgeSeparation.SecondInputTerminal
getset

Input Terminal

◆ Timebase

CITimebase JY5320.TwoEdgeSeparation.Timebase
getset

Timebase configuration

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.QuadEncoder Class Reference

  • QuadEncoder
Properties | List of all members
JY5320.QuadEncoder Class Reference

Configure CI Measure. More...

Properties

QuadEncodingType | EncodingType [get, set]
Type of Encoding More...
bool | ZReloadEnabled [get, set]
In Encoder mode ,the Z signal enable More...
int | InitialCount [get, set]
Initial Count More...
InputTerminal | AInputTerminal [get, set]
Input Terminal More...
InputTerminal | BInputTerminal [get, set]
Input Terminal More...
InputTerminal | ZInputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY5320.QuadEncoder.AInputTerminal
getset

Input Terminal

◆ BInputTerminal

InputTerminal JY5320.QuadEncoder.BInputTerminal
getset

Input Terminal

◆ EncodingType

QuadEncodingType JY5320.QuadEncoder.EncodingType
getset

Type of Encoding

◆ InitialCount

int JY5320.QuadEncoder.InitialCount
getset

Initial Count

◆ ZInputTerminal

InputTerminal JY5320.QuadEncoder.ZInputTerminal
getset

Input Terminal

◆ ZReloadEnabled

bool JY5320.QuadEncoder.ZReloadEnabled
getset

In Encoder mode ,the Z signal enable

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Properties | List of all members
JY5320.TwoPulseEncoder Class Reference

Configure CI Measure. More...

Properties

int | InitialCount [get, set]
Initial Count More...
InputTerminal | AInputTerminal [get, set]
Input Terminal More...
InputTerminal | BInputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY5320.TwoPulseEncoder.AInputTerminal
getset

Input Terminal

◆ BInputTerminal

InputTerminal JY5320.TwoPulseEncoder.BInputTerminal
getset

Input Terminal

◆ InitialCount

int JY5320.TwoPulseEncoder.InitialCount
getset

Initial Count

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.CITrigger Class Reference

  • CITrigger
Properties | List of all members
JY5320.CITrigger Class Reference

Constructor to create an CITrigger task object. More...

Properties

CITriggerType | Type [get, set]
CI trigger type. More...
CIDigitalTrigger | Digital [get, set]
CI Digital Trigger. More...

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Property Documentation

◆ Digital

CIDigitalTrigger JY5320.CITrigger.Digital
getset

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY5320.CITrigger.Type
getset

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Properties | List of all members
JY5320.CIDigitalTrigger Class Reference

CI Digital trigger . More...

Properties

CIDigitalTriggerSource | Source [get, set]
CI Digital Trigger source. More...
CIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

CI Digital trigger .

Property Documentation

◆ Edge

CIDigitalTriggerEdge JY5320.CIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY5320.CIDigitalTrigger.Source
getset

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: JY5320.CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5320.CISignalExport Class Reference

CI Signal Export Class More...

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (CISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

CI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5320.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5320.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JY5320.CISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5320.CISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320CITask.cs


5320 C# Programming Manual: D:/5320/C#/JY5320COTask.cs File Reference

Classes | Namespaces | Enumerations
JY5320COTask.cs File Reference

Classes

class | JY5320.JY5320COTask
JY5320 Counter Output Task More...
class | JY5320.COTrigger
Constructor to create an COTrigger task object. More...
class | JY5320.CODigitalTrigger
CO Digital trigger . More...
class | JY5320.COPulse
Pulse Parameter More...
class | JY5320.COExternalTimebase
class | JY5320.COTimebase
class | JY5320.COSignalExport
CO Signal Export Class More...

Namespaces

namespace JY5320

Enumerations

enum class | JY5320.COIdleState { JY5320.HighLevel = JY5320Import.JY5320_HighLevel , JY5320.LowLevel = JY5320Import.JY5320_LowLevel }
Idle state when pulse output before start and after stop. More...
enum class | JY5320.COMode { JY5320.Single = 3 , JY5320.Finite = 0 , JY5320.ContinuousNoWrapping = 2 , JY5320.ContinuousWrapping = 1 }
CO output mode More...
enum class | JY5320.COTriggerType { JY5320.Immediate = JY5320Import.JY5320_CIO_Immediately , JY5320.Digital = JY5320Import.JY5320_CIO_Digital , JY5320.Soft = JY5320Import.JY5320_CIO_Soft }
TriggerType Digital/Immediate/Soft More...
enum class JY5320.CODigitalTriggerSource {
JY5320.PFI0 = JY5320Import.JY5320_DigitalTriggerSource_PFI_0 , JY5320.PFI1 = JY5320Import.JY5320_DigitalTriggerSource_PFI_1 , JY5320.PFI2 = JY5320Import.JY5320_DigitalTriggerSource_PFI_2 , JY5320.PFI3 = JY5320Import.JY5320_DigitalTriggerSource_PFI_3 ,
JY5320.PFI4 = JY5320Import.JY5320_DigitalTriggerSource_PFI_4 , JY5320.PFI5 = JY5320Import.JY5320_DigitalTriggerSource_PFI_5 , JY5320.PFI6 = JY5320Import.JY5320_DigitalTriggerSource_PFI_6 , JY5320.PFI7 = JY5320Import.JY5320_DigitalTriggerSource_PFI_7 ,
JY5320.PFI8 = JY5320Import.JY5320_DigitalTriggerSource_PFI_8 , JY5320.PFI9 = JY5320Import.JY5320_DigitalTriggerSource_PFI_9 , JY5320.PFI10 = JY5320Import.JY5320_DigitalTriggerSource_PFI_10 , JY5320.PFI11 = JY5320Import.JY5320_DigitalTriggerSource_PFI_11 ,
JY5320.PFI12 = JY5320Import.JY5320_DigitalTriggerSource_PFI_12 , JY5320.PFI13 = JY5320Import.JY5320_DigitalTriggerSource_PFI_13 , JY5320.PFI14 = JY5320Import.JY5320_DigitalTriggerSource_PFI_14 , JY5320.PFI15 = JY5320Import.JY5320_DigitalTriggerSource_PFI_15 ,
JY5320.PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , JY5320.PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , JY5320.PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 , JY5320.PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 ,
JY5320.PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , JY5320.PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , JY5320.PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 , JY5320.PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7 ,
JY5320.AI_StartTrig = JY5320Import.JY5320_AI_StartTrig , JY5320.AI_ReferenceTrig = JY5320Import.JY5320_AI_ReferenceTrig , JY5320.CI_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , JY5320.CI_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig ,
JY5320.CO_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , JY5320.CO_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig , JY5320.CI_0_OutPut = JY5320Import.JY5320_CO_0_Output , JY5320.CI_1_OutPut = JY5320Import.JY5320_CO_1_Output
}
CO Digital trigger source. More...
enum class | JY5320.CODigitalTriggerEdge { JY5320.Rising , JY5320.Falling }
CO Digital Trigger Edge More...
enum class | JY5320.COPulseType { JY5320.DutyCycleFrequency , JY5320.HighLowTime , JY5320.HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | JY5320.COTimebaseSource { JY5320.Internal100MHz = 0 , JY5320.Internal5MHz = 1 , JY5320.Internal100kHz = 2 , JY5320.External = 3 }
enum class | JY5320.COSignalExportSource { JY5320.StartTrig , JY5320.Output }
SourceSignal More...


5320 C# Programming Manual: JY5320.JY5320COTask Class Reference

  • JY5320COTask
Public Member Functions | Properties | List of all members
JY5320.JY5320COTask Class Reference

JY5320 Counter Output Task More...

Public Member Functions

JY5320COTask (int slotNum, int channel)
Constructor. More...
JY5320COTask (string boardName, int channel)
Constructor. More...
void | WriteSinglePoint (COPulse pulse)
Write a single pulse parameter to the register. More...
void | WriteData (COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer. More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
void | Start ()
Start CO task . More...
void | Stop ()
Stop COtask . More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete. More...

Properties

COMode | Mode [get, set]
CO output mode More...
IOTerminal | OutputTerminal [get, set]
COTimebase | Timebase [get, set]
CO's time base. More...
double | InitialDelay [get, set]
Counter output initial delay in seconds. More...
COIdleState | IdleState [get, set]
Idle state when pulse output before start and after stop. More...
uint | SamplesToUpdate [get, set]
有限频率输出 More...
uint | AvaliableLenInSamples [get]
本地缓冲区当前可容纳的样点数（当前每通道可写入缓冲区的样点数） More...
ulong | TransferedSamples [get]
uint | TransferedPulses [get]
COTrigger | Trigger = new COTrigger() [get, set]
CO trigger property configured by CO Trigger(). More...
JY5320Device | Device [get]
Device More...
COSignalExport | SignalExport [get, set]
Export CO Signal Configuration More...

Detailed Description

JY5320 Counter Output Task

Constructor & Destructor Documentation

◆ JY5320COTask() [1/2]

JY5320.JY5320COTask.JY5320COTask | ( | int | slotNum,
 |  | int | channel
 | ) |  |

Constructor.

Used to create an CO task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1）.

◆ JY5320COTask() [2/2]

JY5320.JY5320COTask.JY5320COTask | ( | string | boardName,
 |  | int | channel
 | ) |  |

Constructor.

Used to create an CO task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1）.

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5320.JY5320COTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5320.JY5320COTask.Start ( )

Start CO task .

◆ Stop()

void JY5320.JY5320COTask.Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY5320.JY5320COTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5320.JY5320COTask.WriteData | ( | COPulse[] | pulsesGroup,
 |  | int | samplesToWrite,
 |  | int | timeout = 10000
 | ) |  |

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY5320.JY5320COTask.WriteSinglePoint ( COPulse pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Property Documentation

◆ AvaliableLenInSamples

uint JY5320.JY5320COTask.AvaliableLenInSamples
get

本地缓冲区当前可容纳的样点数（当前每通道可写入缓冲区的样点数）

◆ Device

JY5320Device JY5320.JY5320COTask.Device
get

Device

◆ IdleState

COIdleState JY5320.JY5320COTask.IdleState
getset

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY5320.JY5320COTask.InitialDelay
getset

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JY5320.JY5320COTask.Mode
getset

CO output mode

◆ OutputTerminal

IOTerminal JY5320.JY5320COTask.OutputTerminal
getset

脉冲输出端口

Pulse Output Terminal

◆ SamplesToUpdate

uint JY5320.JY5320COTask.SamplesToUpdate
getset

有限频率输出

◆ SignalExport

COSignalExport JY5320.JY5320COTask.SignalExport
getset

Export CO Signal Configuration

◆ Timebase

COTimebase JY5320.JY5320COTask.Timebase
getset

CO's time base.

◆ TransferedPulses

uint JY5320.JY5320COTask.TransferedPulses
get

当前配置下已发送的脉冲的数量。

The number of pulses transfered under the current configuration.

◆ TransferedSamples

ulong JY5320.JY5320COTask.TransferedSamples
get

已从本地缓冲区传出的样点数（每通道），当 Mode 不为 COMode.Single 时有效。

The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT COMode.Single.

◆ Trigger

COTrigger JY5320.JY5320COTask.Trigger = new COTrigger()
getset

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320COTask.cs


5320 C# Programming Manual: JY5320.COTrigger Class Reference

  • COTrigger
Properties | List of all members
JY5320.COTrigger Class Reference

Constructor to create an COTrigger task object. More...

Properties

COTriggerType | Type [get, set]
CO trigger type. More...
CODigitalTrigger | Digital [get, set]
CO Digital Trigger. More...

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Property Documentation

◆ Digital

CODigitalTrigger JY5320.COTrigger.Digital
getset

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY5320.COTrigger.Type
getset

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320COTask.cs


5320 C# Programming Manual: JY5320.CODigitalTrigger Class Reference

  • CODigitalTrigger
Properties | List of all members
JY5320.CODigitalTrigger Class Reference

CO Digital trigger . More...

Properties

CODigitalTriggerSource | Source [get, set]
CO Digital Trigger source. More...
CODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

CO Digital trigger .

Property Documentation

◆ Edge

CODigitalTriggerEdge JY5320.CODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY5320.CODigitalTrigger.Source
getset

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320COTask.cs


5320 C# Programming Manual: JY5320.COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY5320.COPulse Class Reference

Pulse Parameter More...

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter More...

Detailed Description

Pulse Parameter

Constructor & Destructor Documentation

◆ COPulse()

JY5320.COPulse.COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count
 | ) |  |

Pulse Parameter

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320COTask.cs


5320 C# Programming Manual: JY5320.COExternalTimebase Class Reference

  • COExternalTimebase
Properties | List of all members
JY5320.COExternalTimebase Class Reference

More...

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5320.COExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5320.COExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320COTask.cs


5320 C# Programming Manual: JY5320.COTimebase Class Reference

  • COTimebase
Properties | List of all members
JY5320.COTimebase Class Reference

More...

Properties

COTimebaseSource | Source [get, set]
COExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

COExternalTimebase JY5320.COTimebase.External
getset

外部时基配置。当 COTimebase.Source 为 COTimebaseSource.External时有效。

External Timebase Configuration. Valid when COTimebase.Source is COTimebaseSource.External.

◆ Source

COTimebaseSource JY5320.COTimebase.Source
getset

时基源。默认值为 COTimebaseSource.Internal100MHz。

Timebase Source. The default value is COTimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320COTask.cs


5320 C# Programming Manual: JY5320.COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5320.COSignalExport Class Reference

CO Signal Export Class More...

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (COSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

CO Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5320.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | CO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5320.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | CO Signal Source
destination | Export Desination

◆ Clear()

void JY5320.COSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5320.COSignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320COTask.cs


5320 C# Programming Manual: D:/5320/C#/JY5320DITask.cs File Reference

Classes | Namespaces
JY5320DITask.cs File Reference

Classes

class | JY5320.JY5320DITask
JY5320DITask Class More...
class | JY5320.DIChannel
DI Channel parameter class More...

Namespaces

namespace JY5320


5320 C# Programming Manual: JY5320.JY5320DITask Class Reference

  • JY5320DITask
Public Member Functions | Properties | List of all members
JY5320.JY5320DITask Class Reference

JY5320DITask Class More...

Public Member Functions

JY5320DITask (int slotNum)
Constructor. More...
JY5320DITask (string aliasName)
Constructor. More...
void | AddChannel (int portNum)
Add one port More...
void | AddChannel (int[] portsNum)
Add a group of port More...
void | RemoveChannel (int portNum)
Delete the specified port number More...
void | Start ()
Start DITask More...
void | Stop ()
Stop DITask More...
void | ReadSinglePoint (ref bool[] readValues, int port)
Specify the port reads the latest point More...
void | ReadSinglePoint (ref bool[] readValues)
Each port reads the latest point More...

Properties

JY5320Device | Device [get]
Device Handle More...
List< DIChannel > | Channels [get]
List of DI channels More...

Detailed Description

JY5320DITask Class

Constructor & Destructor Documentation

◆ JY5320DITask() [1/2]

JY5320.JY5320DITask.JY5320DITask ( int slotNum )

Constructor.

Used to create an DItask object

Parameters
slotNum Card slot number

◆ JY5320DITask() [2/2]

JY5320.JY5320DITask.JY5320DITask ( string aliasName )

Constructor.

Used to create an DItask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY5320.JY5320DITask.AddChannel ( int portNum )

Add one port

Parameters
portNum port number

◆ AddChannel() [2/2]

void JY5320.JY5320DITask.AddChannel ( int[] portsNum )

Add a group of port

Parameters
portsNum port number

◆ ReadSinglePoint() [1/2]

void JY5320.JY5320DITask.ReadSinglePoint ( ref bool[] readValues )

Each port reads the latest point

Parameters
readValues User buffer array

◆ ReadSinglePoint() [2/2]

void JY5320.JY5320DITask.ReadSinglePoint | ( | ref bool[] | readValues,
 |  | int | port
 | ) |  |

Specify the port reads the latest point

Parameters
readValues | User buffer array
port | Specify the port to read

◆ RemoveChannel()

void JY5320.JY5320DITask.RemoveChannel ( int portNum )

Delete the specified port number

Parameters
portNum port number

◆ Start()

void JY5320.JY5320DITask.Start ( )

Start DITask

◆ Stop()

void JY5320.JY5320DITask.Stop ( )

Stop DITask

Property Documentation

◆ Channels

List<DIChannel> JY5320.JY5320DITask.Channels
get

List of DI channels

◆ Device

JY5320Device JY5320.JY5320DITask.Device
get

Device Handle

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320DITask.cs


5320 C# Programming Manual: JY5320.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JY5320.DIChannel Class Reference

DI Channel parameter class More...

Properties

int PortNum [get, set]
Port Number More...

Detailed Description

DI Channel parameter class

Property Documentation

◆ PortNum

int JY5320.DIChannel.PortNum
getset

Port Number

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320DITask.cs


5320 C# Programming Manual: D:/5320/C#/JY5320DOTask.cs File Reference

Classes | Namespaces
JY5320DOTask.cs File Reference

Classes

class | JY5320.JY5320DOTask
JY5320 DOTask More...
class | JY5320.DOChannel
DOChannel class More...

Namespaces

namespace JY5320


5320 C# Programming Manual: JY5320.JY5320DOTask Class Reference

  • JY5320DOTask
Public Member Functions | Properties | List of all members
JY5320.JY5320DOTask Class Reference

JY5320 DOTask More...

Public Member Functions

JY5320DOTask (int slotNum)
Constructor. More...
JY5320DOTask (string aliasName)
Constructor. More...
void | AddChannel (int portNum)
Add one port More...
void | AddChannel (int[] portsNum)
Add mulitiple port More...
void | RemoveChannel (int portNum)
delete the specified port number More...
void | Start ()
Start DOTask More...
void | Stop ()
Stop DOTask More...
void | WriteSinglePoint (bool[] writeValues, int port)
write the latest point of Specify port More...
void | WriteSinglePoint (bool[] writeValues)
write the latest point More...

Properties

JY5320Device | Device [get]
Device Handle More...
List< DOChannel > | Channels [get]
List of DO channels More...

Detailed Description

JY5320 DOTask

Constructor & Destructor Documentation

◆ JY5320DOTask() [1/2]

JY5320.JY5320DOTask.JY5320DOTask ( int slotNum )

Constructor.

Used to create an DOtask object

Parameters
slotNum slot Number

◆ JY5320DOTask() [2/2]

JY5320.JY5320DOTask.JY5320DOTask ( string aliasName )

Constructor.

Used to create an DOtask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY5320.JY5320DOTask.AddChannel ( int portNum )

Add one port

Parameters
portNum port number

◆ AddChannel() [2/2]

void JY5320.JY5320DOTask.AddChannel ( int[] portsNum )

Add mulitiple port

Parameters
portsNum port number

◆ RemoveChannel()

void JY5320.JY5320DOTask.RemoveChannel ( int portNum )

delete the specified port number

Parameters
portNum port number

◆ Start()

void JY5320.JY5320DOTask.Start ( )

Start DOTask

◆ Stop()

void JY5320.JY5320DOTask.Stop ( )

Stop DOTask

◆ WriteSinglePoint() [1/2]

void JY5320.JY5320DOTask.WriteSinglePoint ( bool[] writeValues )

write the latest point

Parameters
writeValues User buffer array

◆ WriteSinglePoint() [2/2]

void JY5320.JY5320DOTask.WriteSinglePoint | ( | bool[] | writeValues,
 |  | int | port
 | ) |  |

write the latest point of Specify port

Parameters
writeValues | User buffer array
port | Specify the port to write

Property Documentation

◆ Channels

List<DOChannel> JY5320.JY5320DOTask.Channels
get

List of DO channels

◆ Device

JY5320Device JY5320.JY5320DOTask.Device
get

Device Handle

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320DOTask.cs


5320 C# Programming Manual: JY5320.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY5320.DOChannel Class Reference

DOChannel class More...

Properties

int PortNum [get, set]
port Number More...

Detailed Description

DOChannel class

Property Documentation

◆ PortNum

int JY5320.DOChannel.PortNum
getset

port Number

The documentation for this class was generated from the following file:
  • D:/5320/C#/JY5320DOTask.cs


5320 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5320 |
C JY5320AITask | JY5320 Analog Input Task
C AIChannel | AI Channel parameter class
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | AI Trigger class
C AIDigitalTrigger | AI Digital Trigger
C AIAnalogTrigger | AI Analog Trigger
C AIRecord | AI Record class
C AIAdvanced | AI Advance parameter
C DSMode | DS Mode Class Paraments
C AISync | Configure sync signal
C AISignalExport | AI Signal Export Class
C JY5320CITask | JY5320 Counter Input Task
C CISampleClock | CI Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CITimebase |
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C PauseTrigger | Pause trigger configuration class
C FrequencyMeas | Configure CI Measure
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C SemiPeriodMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C CITrigger | Constructor to create an CITrigger task object
C CIDigitalTrigger | CI Digital trigger
C CISignalExport | CI Signal Export Class
C JY5320COTask | JY5320 Counter Output Task
C COTrigger | Constructor to create an COTrigger task object
C CODigitalTrigger | CO Digital trigger
C COPulse | Pulse Parameter
C COExternalTimebase |
C COTimebase |
C COSignalExport | CO Signal Export Class
C JY5320DITask | JY5320DITask Class
C DIChannel | DI Channel parameter class
C JY5320DOTask | JY5320 DOTask
C DOChannel | DOChannel class


5320 C# Programming Manual: Member List

  • AIAdvanced
JY5320.AIAdvanced Member List

This is the complete list of members for JY5320.AIAdvanced, including all inherited members.

DSMode JY5320.AIAdvanced


5320 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY5320.AIAnalogEdgeComparator Member List

This is the complete list of members for JY5320.AIAnalogEdgeComparator, including all inherited members.

Slope | JY5320.AIAnalogEdgeComparator
Threshold | JY5320.AIAnalogEdgeComparator


5320 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY5320.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5320.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5320.AIAnalogHysteresisComparator
LowThreshold | JY5320.AIAnalogHysteresisComparator
Slope | JY5320.AIAnalogHysteresisComparator


5320 C# Programming Manual: Member List

  • AIAnalogTrigger
JY5320.AIAnalogTrigger Member List

This is the complete list of members for JY5320.AIAnalogTrigger, including all inherited members.

Comparator | JY5320.AIAnalogTrigger
Edge | JY5320.AIAnalogTrigger
Hysteresis | JY5320.AIAnalogTrigger
Source | JY5320.AIAnalogTrigger
Window | JY5320.AIAnalogTrigger


5320 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY5320.AIAnalogWindowComparator Member List

This is the complete list of members for JY5320.AIAnalogWindowComparator, including all inherited members.

Condition | JY5320.AIAnalogWindowComparator
HighThreshold | JY5320.AIAnalogWindowComparator
LowThreshold | JY5320.AIAnalogWindowComparator


5320 C# Programming Manual: Member List

  • AIChannel
JY5320.AIChannel Member List

This is the complete list of members for JY5320.AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AIBandWidth bandWidth) | JY5320.AIChannel
BandWidth | JY5320.AIChannel
ChannelID | JY5320.AIChannel
RangeHigh | JY5320.AIChannel
RangeLow | JY5320.AIChannel


5320 C# Programming Manual: Member List

  • AIDigitalTrigger
JY5320.AIDigitalTrigger Member List

This is the complete list of members for JY5320.AIDigitalTrigger, including all inherited members.

Edge | JY5320.AIDigitalTrigger
Source | JY5320.AIDigitalTrigger


5320 C# Programming Manual: Member List

  • AIExternalSampleClock
JY5320.AIExternalSampleClock Member List

This is the complete list of members for JY5320.AIExternalSampleClock, including all inherited members.

ExpectedRate | JY5320.AIExternalSampleClock
Terminal | JY5320.AIExternalSampleClock


5320 C# Programming Manual: Member List

  • AIRecord
JY5320.AIRecord Member List

This is the complete list of members for JY5320.AIRecord, including all inherited members.

FileFormat | JY5320.AIRecord
FilePath | JY5320.AIRecord
Length | JY5320.AIRecord
Mode | JY5320.AIRecord


5320 C# Programming Manual: Member List

  • AISampleClock
JY5320.AISampleClock Member List

This is the complete list of members for JY5320.AISampleClock, including all inherited members.

External | JY5320.AISampleClock
Source | JY5320.AISampleClock


5320 C# Programming Manual: Member List

  • AISignalExport
JY5320.AISignalExport Member List

This is the complete list of members for JY5320.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5320.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY5320.AISignalExport
Clear(SignalExportDestination destination) | JY5320.AISignalExport
ClearAll() | JY5320.AISignalExport


5320 C# Programming Manual: Member List

  • AISync
JY5320.AISync Member List

This is the complete list of members for JY5320.AISync, including all inherited members.

PulseRouting | JY5320.AISync
Topology | JY5320.AISync
TriggerRouting | JY5320.AISync


5320 C# Programming Manual: Member List

  • AITrigger
JY5320.AITrigger Member List

This is the complete list of members for JY5320.AITrigger, including all inherited members.

Analog | JY5320.AITrigger
Digital | JY5320.AITrigger
Mode | JY5320.AITrigger
PreTriggerSamples | JY5320.AITrigger
ReTriggerCount | JY5320.AITrigger
Type | JY5320.AITrigger


5320 C# Programming Manual: Member List

  • CIDigitalTrigger
JY5320.CIDigitalTrigger Member List

This is the complete list of members for JY5320.CIDigitalTrigger, including all inherited members.

Edge | JY5320.CIDigitalTrigger
Source | JY5320.CIDigitalTrigger


5320 C# Programming Manual: Member List

  • CIExternalSampleClock
JY5320.CIExternalSampleClock Member List

This is the complete list of members for JY5320.CIExternalSampleClock, including all inherited members.

ExpectedRate | JY5320.CIExternalSampleClock
IgnoreFirstSampleClock | JY5320.CIExternalSampleClock
Terminal | JY5320.CIExternalSampleClock


5320 C# Programming Manual: Member List

  • CIExternalTimebase
JY5320.CIExternalTimebase Member List

This is the complete list of members for JY5320.CIExternalTimebase, including all inherited members.

Frequency | JY5320.CIExternalTimebase
Terminal | JY5320.CIExternalTimebase


5320 C# Programming Manual: Member List

  • CIImplicitSampleClock
JY5320.CIImplicitSampleClock Member List

This is the complete list of members for JY5320.CIImplicitSampleClock, including all inherited members.

ExpectedRate JY5320.CIImplicitSampleClock


5320 C# Programming Manual: Member List

  • CIInternalSampleClock
JY5320.CIInternalSampleClock Member List

This is the complete list of members for JY5320.CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY5320.CIInternalSampleClock
Rate | JY5320.CIInternalSampleClock


5320 C# Programming Manual: Member List

  • CISampleClock
JY5320.CISampleClock Member List

This is the complete list of members for JY5320.CISampleClock, including all inherited members.

External | JY5320.CISampleClock
Implicit | JY5320.CISampleClock
Internal | JY5320.CISampleClock
Source | JY5320.CISampleClock


5320 C# Programming Manual: Member List

  • CISignalExport
JY5320.CISignalExport Member List

This is the complete list of members for JY5320.CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5320.CISignalExport
Add(CISignalExportSource source, List< SignalExportDestination > destinations) | JY5320.CISignalExport
Clear(SignalExportDestination destination) | JY5320.CISignalExport
ClearAll() | JY5320.CISignalExport


5320 C# Programming Manual: Member List

  • CITimebase
JY5320.CITimebase Member List

This is the complete list of members for JY5320.CITimebase, including all inherited members.

External | JY5320.CITimebase
Source | JY5320.CITimebase


5320 C# Programming Manual: Member List

  • CITrigger
JY5320.CITrigger Member List

This is the complete list of members for JY5320.CITrigger, including all inherited members.

Digital | JY5320.CITrigger
Type | JY5320.CITrigger


5320 C# Programming Manual: Member List

  • CODigitalTrigger
JY5320.CODigitalTrigger Member List

This is the complete list of members for JY5320.CODigitalTrigger, including all inherited members.

Edge | JY5320.CODigitalTrigger
Source | JY5320.CODigitalTrigger


5320 C# Programming Manual: Member List

  • COExternalTimebase
JY5320.COExternalTimebase Member List

This is the complete list of members for JY5320.COExternalTimebase, including all inherited members.

Frequency | JY5320.COExternalTimebase
Terminal | JY5320.COExternalTimebase


5320 C# Programming Manual: Member List

  • COPulse
JY5320.COPulse Member List

This is the complete list of members for JY5320.COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY5320.COPulse


5320 C# Programming Manual: Member List

  • COSignalExport
JY5320.COSignalExport Member List

This is the complete list of members for JY5320.COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5320.COSignalExport
Add(COSignalExportSource source, List< SignalExportDestination > destinations) | JY5320.COSignalExport
Clear(SignalExportDestination destination) | JY5320.COSignalExport
ClearAll() | JY5320.COSignalExport


5320 C# Programming Manual: Member List

  • COTimebase
JY5320.COTimebase Member List

This is the complete list of members for JY5320.COTimebase, including all inherited members.

External | JY5320.COTimebase
Source | JY5320.COTimebase


5320 C# Programming Manual: Member List

  • COTrigger
JY5320.COTrigger Member List

This is the complete list of members for JY5320.COTrigger, including all inherited members.

Digital | JY5320.COTrigger
Type | JY5320.COTrigger


5320 C# Programming Manual: Member List

  • DIChannel
JY5320.DIChannel Member List

This is the complete list of members for JY5320.DIChannel, including all inherited members.

PortNum JY5320.DIChannel


5320 C# Programming Manual: Member List

  • DOChannel
JY5320.DOChannel Member List

This is the complete list of members for JY5320.DOChannel, including all inherited members.

PortNum JY5320.DOChannel


5320 C# Programming Manual: Member List

  • DSMode
JY5320.DSMode Member List

This is the complete list of members for JY5320.DSMode, including all inherited members.

Enable JY5320.DSMode


5320 C# Programming Manual: Member List

  • EdgeCounting
JY5320.EdgeCounting Member List

This is the complete list of members for JY5320.EdgeCounting, including all inherited members.

ActiveEdge | JY5320.EdgeCounting
Direction | JY5320.EdgeCounting
DirTerminal | JY5320.EdgeCounting
InitialCount | JY5320.EdgeCounting
InputTerminal | JY5320.EdgeCounting
OutEvent | JY5320.EdgeCounting
Pause | JY5320.EdgeCounting


5320 C# Programming Manual: Member List

  • EdgeCountingOutEvent
JY5320.EdgeCountingOutEvent Member List

This is the complete list of members for JY5320.EdgeCountingOutEvent, including all inherited members.

IdleState | JY5320.EdgeCountingOutEvent
Terminal | JY5320.EdgeCountingOutEvent
Threshold | JY5320.EdgeCountingOutEvent


5320 C# Programming Manual: Member List

  • FrequencyMeas
JY5320.FrequencyMeas Member List

This is the complete list of members for JY5320.FrequencyMeas, including all inherited members.

InputTerminal | JY5320.FrequencyMeas
Timebase | JY5320.FrequencyMeas


5320 C# Programming Manual: Member List

  • JY5320AITask
JY5320.JY5320AITask Member List

This is the complete list of members for JY5320.JY5320AITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AIBandWidth bandWidth=AIBandWidth._25KHz) | JY5320.JY5320AITask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10, AIBandWidth bandWidth=AIBandWidth._25KHz) | JY5320.JY5320AITask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh, AIBandWidth[] bandWidth) | JY5320.JY5320AITask
Advanced | JY5320.JY5320AITask
AvailableSamples | JY5320.JY5320AITask
BufLenInSamples | JY5320.JY5320AITask
Channels | JY5320.JY5320AITask
Device | JY5320.JY5320AITask
DisableCalibration | JY5320.JY5320AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout=1000) | JY5320.JY5320AITask
GetRecordPreviewData(ref double[,] buf, int timeout=1000) | JY5320.JY5320AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout=1000) | JY5320.JY5320AITask
GetRecordPreviewData(ref double[] buf, int timeout=1000) | JY5320.JY5320AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JY5320.JY5320AITask
JY5320AITask(int slotNumber) | JY5320.JY5320AITask
JY5320AITask(string boardName) | JY5320.JY5320AITask
Mode | JY5320.JY5320AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout=10000) | JY5320.JY5320AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5320.JY5320AITask
ReadData(ref double[,] buf, int timeout=10000) | JY5320.JY5320AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout=10000) | JY5320.JY5320AITask
ReadData(ref double[] buf, int timeout=10000) | JY5320.JY5320AITask
ReadRawData(ref short[,] buf, int samplesPerChannel, int timeout=10000) | JY5320.JY5320AITask
ReadRawData(ref short[,] buf, int timeout=10000) | JY5320.JY5320AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5320.JY5320AITask
ReadRawData(ref short[] buf, int samplesPerChannel, int timeout=10000) | JY5320.JY5320AITask
ReadRawData(ref short[] buf, int timeout=10000) | JY5320.JY5320AITask
ReadRawData(ref int[,] buf, int samplesPerChannel, int timeout=10000) | JY5320.JY5320AITask
ReadRawData(ref int[,] buf, int timeout=10000) | JY5320.JY5320AITask
ReadRawData(ref int[] buf, int samplesPerChannel, int timeout=10000) | JY5320.JY5320AITask
ReadRawData(ref int[] buf, int timeout=10000) | JY5320.JY5320AITask
ReadSinglePoint(ref double readValue, int channel) | JY5320.JY5320AITask
ReadSinglePoint(ref double[] readValues) | JY5320.JY5320AITask
Record | JY5320.JY5320AITask
RemoveChannel(int chnId) | JY5320.JY5320AITask
SampleClock | JY5320.JY5320AITask
SampleRate | JY5320.JY5320AITask
SamplesToAcquire | JY5320.JY5320AITask
SendSoftwareTrigger() | JY5320.JY5320AITask
SignalExport | JY5320.JY5320AITask
Start() | JY5320.JY5320AITask
Stop() | JY5320.JY5320AITask
Sync | JY5320.JY5320AITask
TransferedSamples | JY5320.JY5320AITask
Trigger | JY5320.JY5320AITask
WaitUntilDone(int timeout=-1) | JY5320.JY5320AITask


5320 C# Programming Manual: Member List

  • JY5320CITask
JY5320.JY5320CITask Member List

This is the complete list of members for JY5320.JY5320CITask, including all inherited members.

AvailableSamples | JY5320.JY5320CITask
Device | JY5320.JY5320CITask
EdgeCounting | JY5320.JY5320CITask
FrequencyMeas | JY5320.JY5320CITask
JY5320CITask(int slotNum, int channel) | JY5320.JY5320CITask
JY5320CITask(string boardName, int channel) | JY5320.JY5320CITask
Mode | JY5320.JY5320CITask
PeriodMeas | JY5320.JY5320CITask
PulseMeas | JY5320.JY5320CITask
QuadEncoder | JY5320.JY5320CITask
ReadData(ref uint[] bufCount, int samplesToAcquire, int timeout=10000) | JY5320.JY5320CITask
ReadData(ref uint[] bufCount, int timeout=10000) | JY5320.JY5320CITask
ReadData(ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000) | JY5320.JY5320CITask
ReadData(ref double[] bufMeasurement, int timeout=10000) | JY5320.JY5320CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5320.JY5320CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000) | JY5320.JY5320CITask
ReadSinglePoint(ref uint count) | JY5320.JY5320CITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JY5320.JY5320CITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JY5320.JY5320CITask
SampleClock | JY5320.JY5320CITask
SamplesToAcquire | JY5320.JY5320CITask
SemiPeriodMeas | JY5320.JY5320CITask
SendSoftwareTrigger() | JY5320.JY5320CITask
SignalExport | JY5320.JY5320CITask
Start() | JY5320.JY5320CITask
Stop() | JY5320.JY5320CITask
TransferedSamples | JY5320.JY5320CITask
Trigger | JY5320.JY5320CITask
TwoEdgeSeparation | JY5320.JY5320CITask
TwoPulseEncoder | JY5320.JY5320CITask
Type | JY5320.JY5320CITask


5320 C# Programming Manual: Member List

  • JY5320COTask
JY5320.JY5320COTask Member List

This is the complete list of members for JY5320.JY5320COTask, including all inherited members.

AvaliableLenInSamples | JY5320.JY5320COTask
Device | JY5320.JY5320COTask
IdleState | JY5320.JY5320COTask
InitialDelay | JY5320.JY5320COTask
JY5320COTask(int slotNum, int channel) | JY5320.JY5320COTask
JY5320COTask(string boardName, int channel) | JY5320.JY5320COTask
Mode | JY5320.JY5320COTask
OutputTerminal | JY5320.JY5320COTask
SamplesToUpdate | JY5320.JY5320COTask
SendSoftwareTrigger() | JY5320.JY5320COTask
SignalExport | JY5320.JY5320COTask
Start() | JY5320.JY5320COTask
Stop() | JY5320.JY5320COTask
Timebase | JY5320.JY5320COTask
TransferedPulses | JY5320.JY5320COTask
TransferedSamples | JY5320.JY5320COTask
Trigger | JY5320.JY5320COTask
WaitUntilDone(int timeout=-1) | JY5320.JY5320COTask
WriteData(COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000) | JY5320.JY5320COTask
WriteSinglePoint(COPulse pulse) | JY5320.JY5320COTask


5320 C# Programming Manual: Member List

  • JY5320DITask
JY5320.JY5320DITask Member List

This is the complete list of members for JY5320.JY5320DITask, including all inherited members.

AddChannel(int portNum) | JY5320.JY5320DITask
AddChannel(int[] portsNum) | JY5320.JY5320DITask
Channels | JY5320.JY5320DITask
Device | JY5320.JY5320DITask
JY5320DITask(int slotNum) | JY5320.JY5320DITask
JY5320DITask(string aliasName) | JY5320.JY5320DITask
ReadSinglePoint(ref bool[] readValues, int port) | JY5320.JY5320DITask
ReadSinglePoint(ref bool[] readValues) | JY5320.JY5320DITask
RemoveChannel(int portNum) | JY5320.JY5320DITask
Start() | JY5320.JY5320DITask
Stop() | JY5320.JY5320DITask


5320 C# Programming Manual: Member List

  • JY5320DOTask
JY5320.JY5320DOTask Member List

This is the complete list of members for JY5320.JY5320DOTask, including all inherited members.

AddChannel(int portNum) | JY5320.JY5320DOTask
AddChannel(int[] portsNum) | JY5320.JY5320DOTask
Channels | JY5320.JY5320DOTask
Device | JY5320.JY5320DOTask
JY5320DOTask(int slotNum) | JY5320.JY5320DOTask
JY5320DOTask(string aliasName) | JY5320.JY5320DOTask
RemoveChannel(int portNum) | JY5320.JY5320DOTask
Start() | JY5320.JY5320DOTask
Stop() | JY5320.JY5320DOTask
WriteSinglePoint(bool[] writeValues, int port) | JY5320.JY5320DOTask
WriteSinglePoint(bool[] writeValues) | JY5320.JY5320DOTask


5320 C# Programming Manual: Member List

  • PauseTrigger
JY5320.PauseTrigger Member List

This is the complete list of members for JY5320.PauseTrigger, including all inherited members.

ActivePolarity | JY5320.PauseTrigger
Terminal | JY5320.PauseTrigger


5320 C# Programming Manual: Member List

  • PeriodMeas
JY5320.PeriodMeas Member List

This is the complete list of members for JY5320.PeriodMeas, including all inherited members.

InputTerminal | JY5320.PeriodMeas
Timebase | JY5320.PeriodMeas


5320 C# Programming Manual: Member List

  • PulseMeas
JY5320.PulseMeas Member List

This is the complete list of members for JY5320.PulseMeas, including all inherited members.

InputTerminal | JY5320.PulseMeas
StartingEdge | JY5320.PulseMeas
Timebase | JY5320.PulseMeas


5320 C# Programming Manual: Member List

  • QuadEncoder
JY5320.QuadEncoder Member List

This is the complete list of members for JY5320.QuadEncoder, including all inherited members.

AInputTerminal | JY5320.QuadEncoder
BInputTerminal | JY5320.QuadEncoder
EncodingType | JY5320.QuadEncoder
InitialCount | JY5320.QuadEncoder
ZInputTerminal | JY5320.QuadEncoder
ZReloadEnabled | JY5320.QuadEncoder


5320 C# Programming Manual: Member List

  • SemiPeriodMeas
JY5320.SemiPeriodMeas Member List

This is the complete list of members for JY5320.SemiPeriodMeas, including all inherited members.

InputTerminal | JY5320.SemiPeriodMeas
StartingEdge | JY5320.SemiPeriodMeas
Timebase | JY5320.SemiPeriodMeas


5320 C# Programming Manual: Member List

  • TwoEdgeSeparation
JY5320.TwoEdgeSeparation Member List

This is the complete list of members for JY5320.TwoEdgeSeparation, including all inherited members.

FirstInputTerminal | JY5320.TwoEdgeSeparation
SecondInputTerminal | JY5320.TwoEdgeSeparation
Timebase | JY5320.TwoEdgeSeparation


5320 C# Programming Manual: Member List

  • TwoPulseEncoder
JY5320.TwoPulseEncoder Member List

This is the complete list of members for JY5320.TwoPulseEncoder, including all inherited members.

AInputTerminal | JY5320.TwoPulseEncoder
BInputTerminal | JY5320.TwoPulseEncoder
InitialCount | JY5320.TwoPulseEncoder


5320 C# Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIAdvanced (JY5320)
AIAnalogEdgeComparator (JY5320)
AIAnalogHysteresisComparator (JY5320)
AIAnalogTrigger (JY5320)
AIAnalogWindowComparator (JY5320)
AIChannel (JY5320)
AIDigitalTrigger (JY5320)
AIExternalSampleClock (JY5320)
AIRecord (JY5320)
AISampleClock (JY5320)
AISignalExport (JY5320)
AISync (JY5320)
AITrigger (JY5320)
C
CIDigitalTrigger (JY5320)
CIExternalSampleClock (JY5320)
CIExternalTimebase (JY5320)
CIImplicitSampleClock (JY5320)
CIInternalSampleClock (JY5320)
CISampleClock (JY5320)
CISignalExport (JY5320)
CITimebase (JY5320)
CITrigger (JY5320)
CODigitalTrigger (JY5320)
COExternalTimebase (JY5320)
COPulse (JY5320)
COSignalExport (JY5320)
COTimebase (JY5320)
COTrigger (JY5320)
D
DIChannel (JY5320)
DOChannel (JY5320)
DSMode (JY5320)
E
EdgeCounting (JY5320)
EdgeCountingOutEvent (JY5320)
F
FrequencyMeas (JY5320)
J
JY5320AITask (JY5320)
JY5320CITask (JY5320)
JY5320COTask (JY5320)
JY5320DITask (JY5320)
JY5320DOTask (JY5320)
P
PauseTrigger (JY5320)
PeriodMeas (JY5320)
PulseMeas (JY5320)
Q
QuadEncoder (JY5320)
S
SemiPeriodMeas (JY5320)
T
TwoEdgeSeparation (JY5320)
TwoPulseEncoder (JY5320)


5320 C# Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 5320


5320 C# Programming Manual: D:/5320 Directory Reference

  • D:
  • 5320
5320 Directory Reference

Directories

directory C#


5320 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 5320
▼ C#
JY5320AITask.cs
JY5320CITask.cs
JY5320COTask.cs
JY5320DITask.cs
JY5320DOTask.cs


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY5320.EdgeCounting
  • ActivePolarity : JY5320.PauseTrigger
  • Add() : JY5320.AISignalExport , JY5320.CISignalExport , JY5320.COSignalExport
  • AddChannel() : JY5320.JY5320AITask , JY5320.JY5320DITask , JY5320.JY5320DOTask
  • Advanced : JY5320.JY5320AITask
  • AIChannel() : JY5320.AIChannel
  • AInputTerminal : JY5320.QuadEncoder , JY5320.TwoPulseEncoder
  • Analog : JY5320.AITrigger
  • AvailableSamples : JY5320.JY5320AITask , JY5320.JY5320CITask
  • AvaliableLenInSamples : JY5320.JY5320COTask


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- b -

  • BandWidth : JY5320.AIChannel
  • BInputTerminal : JY5320.QuadEncoder , JY5320.TwoPulseEncoder
  • BufLenInSamples : JY5320.JY5320AITask


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JY5320.AIChannel
  • Channels : JY5320.JY5320AITask , JY5320.JY5320DITask , JY5320.JY5320DOTask
  • Clear() : JY5320.AISignalExport , JY5320.CISignalExport , JY5320.COSignalExport
  • ClearAll() : JY5320.AISignalExport , JY5320.CISignalExport , JY5320.COSignalExport
  • Comparator : JY5320.AIAnalogTrigger
  • Condition : JY5320.AIAnalogWindowComparator
  • COPulse() : JY5320.COPulse


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask , JY5320.JY5320DITask , JY5320.JY5320DOTask
  • Digital : JY5320.AITrigger , JY5320.CITrigger , JY5320.COTrigger
  • Direction : JY5320.EdgeCounting
  • DirTerminal : JY5320.EdgeCounting
  • DisableCalibration : JY5320.JY5320AITask
  • DSMode : JY5320.AIAdvanced


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY5320.AIAnalogTrigger , JY5320.AIDigitalTrigger , JY5320.CIDigitalTrigger , JY5320.CODigitalTrigger
  • EdgeCounting : JY5320.JY5320CITask
  • Enable : JY5320.DSMode
  • EncodingType : JY5320.QuadEncoder
  • ExpectedRate : JY5320.AIExternalSampleClock , JY5320.CIExternalSampleClock , JY5320.CIImplicitSampleClock
  • External : JY5320.AISampleClock , JY5320.CISampleClock , JY5320.CITimebase , JY5320.COTimebase


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- f -

  • FileFormat : JY5320.AIRecord
  • FilePath : JY5320.AIRecord
  • FirstInputTerminal : JY5320.TwoEdgeSeparation
  • Frequency : JY5320.CIExternalTimebase , JY5320.COExternalTimebase
  • FrequencyMeas : JY5320.JY5320CITask


5320 C# Programming Manual: Class Members - Functions

- a -

  • Add() : JY5320.AISignalExport , JY5320.CISignalExport , JY5320.COSignalExport
  • AddChannel() : JY5320.JY5320AITask , JY5320.JY5320DITask , JY5320.JY5320DOTask
  • AIChannel() : JY5320.AIChannel

- c -

  • Clear() : JY5320.AISignalExport , JY5320.CISignalExport , JY5320.COSignalExport
  • ClearAll() : JY5320.AISignalExport , JY5320.CISignalExport , JY5320.COSignalExport
  • COPulse() : JY5320.COPulse

- g -

  • GetRecordPreviewData() : JY5320.JY5320AITask
  • GetRecordStatus() : JY5320.JY5320AITask

- j -

  • JY5320AITask() : JY5320.JY5320AITask
  • JY5320CITask() : JY5320.JY5320CITask
  • JY5320COTask() : JY5320.JY5320COTask
  • JY5320DITask() : JY5320.JY5320DITask
  • JY5320DOTask() : JY5320.JY5320DOTask

- r -

  • ReadData() : JY5320.JY5320AITask , JY5320.JY5320CITask
  • ReadRawData() : JY5320.JY5320AITask
  • ReadSinglePoint() : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320DITask
  • RemoveChannel() : JY5320.JY5320AITask , JY5320.JY5320DITask , JY5320.JY5320DOTask

- s -

  • SendSoftwareTrigger() : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask
  • Start() : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask , JY5320.JY5320DITask , JY5320.JY5320DOTask
  • Stop() : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask , JY5320.JY5320DITask , JY5320.JY5320DOTask

- w -

  • WaitUntilDone() : JY5320.JY5320AITask , JY5320.JY5320COTask
  • WriteData() : JY5320.JY5320COTask
  • WriteSinglePoint() : JY5320.JY5320COTask , JY5320.JY5320DOTask


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- g -

  • GetRecordPreviewData() : JY5320.JY5320AITask
  • GetRecordStatus() : JY5320.JY5320AITask


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- h -

  • HighThreshold : JY5320.AIAnalogHysteresisComparator , JY5320.AIAnalogWindowComparator
  • Hysteresis : JY5320.AIAnalogTrigger


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JY5320.EdgeCountingOutEvent , JY5320.JY5320COTask
  • IgnoreFirstSampleClock : JY5320.CIExternalSampleClock , JY5320.CIInternalSampleClock
  • Implicit : JY5320.CISampleClock
  • InitialCount : JY5320.EdgeCounting , JY5320.QuadEncoder , JY5320.TwoPulseEncoder
  • InitialDelay : JY5320.JY5320COTask
  • InputTerminal : JY5320.EdgeCounting , JY5320.FrequencyMeas , JY5320.PeriodMeas , JY5320.PulseMeas , JY5320.SemiPeriodMeas
  • Internal : JY5320.CISampleClock


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- j -

  • JY5320AITask() : JY5320.JY5320AITask
  • JY5320CITask() : JY5320.JY5320CITask
  • JY5320COTask() : JY5320.JY5320COTask
  • JY5320DITask() : JY5320.JY5320DITask
  • JY5320DOTask() : JY5320.JY5320DOTask


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JY5320.AIRecord
  • LowThreshold : JY5320.AIAnalogHysteresisComparator , JY5320.AIAnalogWindowComparator


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- m -

  • Mode : JY5320.AIRecord , JY5320.AITrigger , JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- o -

  • OutEvent : JY5320.EdgeCounting
  • OutputTerminal : JY5320.JY5320COTask


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JY5320.EdgeCounting
  • PeriodMeas : JY5320.JY5320CITask
  • PortNum : JY5320.DIChannel , JY5320.DOChannel
  • PreTriggerSamples : JY5320.AITrigger
  • PulseMeas : JY5320.JY5320CITask
  • PulseRouting : JY5320.AISync


5320 C# Programming Manual: Class Members - Properties

- a -

  • ActiveEdge : JY5320.EdgeCounting
  • ActivePolarity : JY5320.PauseTrigger
  • Advanced : JY5320.JY5320AITask
  • AInputTerminal : JY5320.QuadEncoder , JY5320.TwoPulseEncoder
  • Analog : JY5320.AITrigger
  • AvailableSamples : JY5320.JY5320AITask , JY5320.JY5320CITask
  • AvaliableLenInSamples : JY5320.JY5320COTask

- b -

  • BandWidth : JY5320.AIChannel
  • BInputTerminal : JY5320.QuadEncoder , JY5320.TwoPulseEncoder
  • BufLenInSamples : JY5320.JY5320AITask

- c -

  • ChannelID : JY5320.AIChannel
  • Channels : JY5320.JY5320AITask , JY5320.JY5320DITask , JY5320.JY5320DOTask
  • Comparator : JY5320.AIAnalogTrigger
  • Condition : JY5320.AIAnalogWindowComparator

- d -

  • Device : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask , JY5320.JY5320DITask , JY5320.JY5320DOTask
  • Digital : JY5320.AITrigger , JY5320.CITrigger , JY5320.COTrigger
  • Direction : JY5320.EdgeCounting
  • DirTerminal : JY5320.EdgeCounting
  • DisableCalibration : JY5320.JY5320AITask
  • DSMode : JY5320.AIAdvanced

- e -

  • Edge : JY5320.AIAnalogTrigger , JY5320.AIDigitalTrigger , JY5320.CIDigitalTrigger , JY5320.CODigitalTrigger
  • EdgeCounting : JY5320.JY5320CITask
  • Enable : JY5320.DSMode
  • EncodingType : JY5320.QuadEncoder
  • ExpectedRate : JY5320.AIExternalSampleClock , JY5320.CIExternalSampleClock , JY5320.CIImplicitSampleClock
  • External : JY5320.AISampleClock , JY5320.CISampleClock , JY5320.CITimebase , JY5320.COTimebase

- f -

  • FileFormat : JY5320.AIRecord
  • FilePath : JY5320.AIRecord
  • FirstInputTerminal : JY5320.TwoEdgeSeparation
  • Frequency : JY5320.CIExternalTimebase , JY5320.COExternalTimebase
  • FrequencyMeas : JY5320.JY5320CITask

- h -

  • Hysteresis : JY5320.AIAnalogTrigger

- i -

  • IdleState : JY5320.EdgeCountingOutEvent , JY5320.JY5320COTask
  • IgnoreFirstSampleClock : JY5320.CIExternalSampleClock , JY5320.CIInternalSampleClock
  • Implicit : JY5320.CISampleClock
  • InitialCount : JY5320.EdgeCounting , JY5320.QuadEncoder , JY5320.TwoPulseEncoder
  • InitialDelay : JY5320.JY5320COTask
  • InputTerminal : JY5320.EdgeCounting , JY5320.FrequencyMeas , JY5320.PeriodMeas , JY5320.PulseMeas , JY5320.SemiPeriodMeas
  • Internal : JY5320.CISampleClock

- l -

  • Length : JY5320.AIRecord

- m -

  • Mode : JY5320.AIRecord , JY5320.AITrigger , JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask

- o -

  • OutEvent : JY5320.EdgeCounting
  • OutputTerminal : JY5320.JY5320COTask

- p -

  • Pause : JY5320.EdgeCounting
  • PeriodMeas : JY5320.JY5320CITask
  • PortNum : JY5320.DIChannel , JY5320.DOChannel
  • PreTriggerSamples : JY5320.AITrigger
  • PulseMeas : JY5320.JY5320CITask
  • PulseRouting : JY5320.AISync

- q -

  • QuadEncoder : JY5320.JY5320CITask

- r -

  • RangeHigh : JY5320.AIChannel
  • RangeLow : JY5320.AIChannel
  • Rate : JY5320.CIInternalSampleClock
  • Record : JY5320.JY5320AITask
  • ReTriggerCount : JY5320.AITrigger

- s -

  • SampleClock : JY5320.JY5320AITask , JY5320.JY5320CITask
  • SampleRate : JY5320.JY5320AITask
  • SamplesToAcquire : JY5320.JY5320AITask , JY5320.JY5320CITask
  • SamplesToUpdate : JY5320.JY5320COTask
  • SecondInputTerminal : JY5320.TwoEdgeSeparation
  • SemiPeriodMeas : JY5320.JY5320CITask
  • SignalExport : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask
  • Slope : JY5320.AIAnalogEdgeComparator , JY5320.AIAnalogHysteresisComparator
  • Source : JY5320.AIAnalogTrigger , JY5320.AIDigitalTrigger , JY5320.AISampleClock , JY5320.CIDigitalTrigger , JY5320.CISampleClock , JY5320.CITimebase , JY5320.CODigitalTrigger , JY5320.COTimebase
  • StartingEdge : JY5320.PulseMeas , JY5320.SemiPeriodMeas
  • Sync : JY5320.JY5320AITask

- t -

  • Terminal : JY5320.AIExternalSampleClock , JY5320.CIExternalSampleClock , JY5320.CIExternalTimebase , JY5320.COExternalTimebase , JY5320.EdgeCountingOutEvent , JY5320.PauseTrigger
  • Threshold : JY5320.EdgeCountingOutEvent
  • Timebase : JY5320.FrequencyMeas , JY5320.JY5320COTask , JY5320.PeriodMeas , JY5320.PulseMeas , JY5320.SemiPeriodMeas , JY5320.TwoEdgeSeparation
  • Topology : JY5320.AISync
  • TransferedPulses : JY5320.JY5320COTask
  • TransferedSamples : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask
  • Trigger : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask
  • TriggerRouting : JY5320.AISync
  • TwoEdgeSeparation : JY5320.JY5320CITask
  • TwoPulseEncoder : JY5320.JY5320CITask
  • Type : JY5320.AITrigger , JY5320.CITrigger , JY5320.COTrigger , JY5320.JY5320CITask

- w -

  • Window : JY5320.AIAnalogTrigger

- z -

  • ZInputTerminal : JY5320.QuadEncoder
  • ZReloadEnabled : JY5320.QuadEncoder


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JY5320.JY5320CITask


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY5320.AIChannel
  • RangeLow : JY5320.AIChannel
  • Rate : JY5320.CIInternalSampleClock
  • ReadData() : JY5320.JY5320AITask , JY5320.JY5320CITask
  • ReadRawData() : JY5320.JY5320AITask
  • ReadSinglePoint() : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320DITask
  • Record : JY5320.JY5320AITask
  • RemoveChannel() : JY5320.JY5320AITask , JY5320.JY5320DITask , JY5320.JY5320DOTask
  • ReTriggerCount : JY5320.AITrigger


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JY5320.JY5320AITask , JY5320.JY5320CITask
  • SampleRate : JY5320.JY5320AITask
  • SamplesToAcquire : JY5320.JY5320AITask , JY5320.JY5320CITask
  • SamplesToUpdate : JY5320.JY5320COTask
  • SecondInputTerminal : JY5320.TwoEdgeSeparation
  • SemiPeriodMeas : JY5320.JY5320CITask
  • SendSoftwareTrigger() : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask
  • SignalExport : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask
  • Slope : JY5320.AIAnalogEdgeComparator , JY5320.AIAnalogHysteresisComparator
  • Source : JY5320.AIAnalogTrigger , JY5320.AIDigitalTrigger , JY5320.AISampleClock , JY5320.CIDigitalTrigger , JY5320.CISampleClock , JY5320.CITimebase , JY5320.CODigitalTrigger , JY5320.COTimebase
  • Start() : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask , JY5320.JY5320DITask , JY5320.JY5320DOTask
  • StartingEdge : JY5320.PulseMeas , JY5320.SemiPeriodMeas
  • Stop() : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask , JY5320.JY5320DITask , JY5320.JY5320DOTask
  • Sync : JY5320.JY5320AITask


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JY5320.AIExternalSampleClock , JY5320.CIExternalSampleClock , JY5320.CIExternalTimebase , JY5320.COExternalTimebase , JY5320.EdgeCountingOutEvent , JY5320.PauseTrigger
  • Threshold : JY5320.AIAnalogEdgeComparator , JY5320.EdgeCountingOutEvent
  • Timebase : JY5320.FrequencyMeas , JY5320.JY5320COTask , JY5320.PeriodMeas , JY5320.PulseMeas , JY5320.SemiPeriodMeas , JY5320.TwoEdgeSeparation
  • Topology : JY5320.AISync
  • TransferedPulses : JY5320.JY5320COTask
  • TransferedSamples : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask
  • Trigger : JY5320.JY5320AITask , JY5320.JY5320CITask , JY5320.JY5320COTask
  • TriggerRouting : JY5320.AISync
  • TwoEdgeSeparation : JY5320.JY5320CITask
  • TwoPulseEncoder : JY5320.JY5320CITask
  • Type : JY5320.AITrigger , JY5320.CITrigger , JY5320.COTrigger , JY5320.JY5320CITask


5320 C# Programming Manual: Class Members - Variables

  • HighThreshold : JY5320.AIAnalogHysteresisComparator , JY5320.AIAnalogWindowComparator
  • LowThreshold : JY5320.AIAnalogHysteresisComparator , JY5320.AIAnalogWindowComparator
  • Threshold : JY5320.AIAnalogEdgeComparator


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JY5320.JY5320AITask , JY5320.JY5320COTask
  • Window : JY5320.AIAnalogTrigger
  • WriteData() : JY5320.JY5320COTask
  • WriteSinglePoint() : JY5320.JY5320COTask , JY5320.JY5320DOTask


5320 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5320.QuadEncoder
  • ZReloadEnabled : JY5320.QuadEncoder


5320 C# Programming Manual: Main Page

5320 C# Programming Manual Documentation


5320 C# Programming Manual: JY5320 Namespace Reference

Classes | Enumerations
JY5320 Namespace Reference

Classes

class | JY5320AITask
JY5320 Analog Input Task. More...
class | AIChannel
AI Channel parameter class More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator More...
class | AISampleClock
Sample clock configuration class More...
class | AIExternalSampleClock
External Sample Clock Configuration Class More...
class | AITrigger
AI Trigger class More...
class | AIDigitalTrigger
AI Digital Trigger More...
class | AIAnalogTrigger
AI Analog Trigger More...
class | AIRecord
AI Record class More...
class | AIAdvanced
AI Advance parameter More...
class | DSMode
DS Mode Class Paraments More...
class | AISync
Configure sync signal More...
class | AISignalExport
AI Signal Export Class More...
class | JY5320CITask
JY5320 Counter Input Task More...
class | CISampleClock
CI Sample Clock class More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class More...
class | CIImplicitSampleClock
CI Implicit Sample Clock class More...
class | CIExternalSampleClock
CI Implicit Sample Clock class More...
class | CIExternalTimebase
class | CITimebase
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class More...
class | PauseTrigger
Pause trigger configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CISignalExport
CI Signal Export Class More...
class | JY5320COTask
JY5320 Counter Output Task More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COPulse
Pulse Parameter More...
class | COExternalTimebase
class | COTimebase
class | COSignalExport
CO Signal Export Class More...
class | JY5320DITask
JY5320DITask Class More...
class | DIChannel
DI Channel parameter class More...
class | JY5320DOTask
JY5320 DOTask More...
class | DOChannel
DOChannel class More...

Enumerations

enum class | AIBandWidth { _25KHz = JY5320Import.JY5320_AI_BandWidth_25K , _220KHz = JY5320Import.JY5320_AI_BandWidth_220K }
AI BandWidth More...
enum class | AITriggerType { Immediate = JY5320Import.JY5320_TriggerType_Immediately , Digital = JY5320Import.JY5320_TriggerType_Digital , Analog = JY5320Import.JY5320_TriggerType_Analog , Soft = JY5320Import.JY5320_TriggerType_Soft }
Trigger Type: Digital/Analog/Immediate More...
enum class | AIDigitalTriggerEdge { Rising = JY5320Import.JY5320_DigitalTriggerEdge_Rising , Falling = JY5320Import.JY5320_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge More...
enum class | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge More...
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator More...
enum class | AIMode { Single = JY5320Import.JY5320_AI_Single , Finite = JY5320Import.JY5320_AI_Finite , Continuous = JY5320Import.JY5320_AI_Continuous , Record = 0x3 }
AIMode More...
enum class | AISampleClockSource { Internal = JY5320Import.JY5320_AI_InternalClock , External = JY5320Import.JY5320_AI_ExternalClock }
AIClockSource Type More...
enum class ClockTerminal {
PFI0 = JY5320Import.JY5320_DigitalTriggerSource_PFI_0 , PFI1 = JY5320Import.JY5320_DigitalTriggerSource_PFI_1 , PFI2 = JY5320Import.JY5320_DigitalTriggerSource_PFI_2 , PFI3 = JY5320Import.JY5320_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5320Import.JY5320_DigitalTriggerSource_PFI_4 , PFI5 = JY5320Import.JY5320_DigitalTriggerSource_PFI_5 , PFI6 = JY5320Import.JY5320_DigitalTriggerSource_PFI_6 , PFI7 = JY5320Import.JY5320_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5320Import.JY5320_DigitalTriggerSource_PFI_8 , PFI9 = JY5320Import.JY5320_DigitalTriggerSource_PFI_9 , PFI10 = JY5320Import.JY5320_DigitalTriggerSource_PFI_10 , PFI11 = JY5320Import.JY5320_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5320Import.JY5320_DigitalTriggerSource_PFI_12 , PFI13 = JY5320Import.JY5320_DigitalTriggerSource_PFI_13 , PFI14 = JY5320Import.JY5320_DigitalTriggerSource_PFI_14 , PFI15 = JY5320Import.JY5320_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7 ,
AI_SampleClock = JY5320Import.JY5320_AI_SampleClock , CI0_SampleClock = JY5320Import.JY5320_CI0_SampleClock , CI1_SampleClock = JY5320Import.JY5320_CI1_SampleClock , CO0_Output = JY5320Import.JY5320_CO_0_Output ,
CO1_Output = JY5320Import.JY5320_CO_1_Output
}
External Sample Clock Terminal More...
enum class | AITriggerMode { Start , Reference }
AI Trigger Mode More...
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31
}
AI Analog Trigger Source More...
enum class AIDigitalTriggerSource {
PFI0 = JY5320Import.JY5320_DigitalTriggerSource_PFI_0 , PFI1 = JY5320Import.JY5320_DigitalTriggerSource_PFI_1 , PFI2 = JY5320Import.JY5320_DigitalTriggerSource_PFI_2 , PFI3 = JY5320Import.JY5320_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5320Import.JY5320_DigitalTriggerSource_PFI_4 , PFI5 = JY5320Import.JY5320_DigitalTriggerSource_PFI_5 , PFI6 = JY5320Import.JY5320_DigitalTriggerSource_PFI_6 , PFI7 = JY5320Import.JY5320_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5320Import.JY5320_DigitalTriggerSource_PFI_8 , PFI9 = JY5320Import.JY5320_DigitalTriggerSource_PFI_9 , PFI10 = JY5320Import.JY5320_DigitalTriggerSource_PFI_10 , PFI11 = JY5320Import.JY5320_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5320Import.JY5320_DigitalTriggerSource_PFI_12 , PFI13 = JY5320Import.JY5320_DigitalTriggerSource_PFI_13 , PFI14 = JY5320Import.JY5320_DigitalTriggerSource_PFI_14 , PFI15 = JY5320Import.JY5320_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7 ,
CI_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , CI_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig , CO_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , CO_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig ,
CI_0_OutPut = JY5320Import.JY5320_CO_0_Output , CI_1_OutPut = JY5320Import.JY5320_CO_1_Output
}
AI Digital Trigger Source More...
enum class | FileFormat { Bin }
Streaming file format More...
enum class | RecordMode { Finite , Infinite }
Two stream mode from enum Finite/Infinite More...
enum class | SyncTopology { Independent , Master , Slave }
Synchronization board configuration More...
enum class SyncTriggerRouting {
NONE = -1 , PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 ,
PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 , PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 ,
PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7
}
Master card trigger signal routing (Master card routes trigger signal to this port) More...
enum class SyncPulseRouting {
NONE = -1 , PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 ,
PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 , PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 ,
PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) More...
enum class | AISignalExportSource { StartTrig = 4 , ReferenceTrig = 6 , SampleClock = 1 }
AI Signal Export Source More...
enum class SignalExportDestination {
PFI0 = 8 , PFI1 = 9 , PFI2 = 10 , PFI3 = 11 ,
PFI4 = 12 , PFI5 = 13 , PFI6 = 14 , PFI7 = 15 ,
PFI8 = 16 , PFI9 = 17 , PFI10 = 18 , PFI11 = 19 ,
PFI12 = 20 , PFI13 = 21 , PFI14 = 22 , PFI15 = 23 ,
PXI_Trig0 = 0 , PXI_Trig1 = 1 , PXI_Trig2 = 2 , PXI_Trig3 = 3 ,
PXI_Trig4 = 4 , PXI_Trig5 = 5 , PXI_Trig6 = 6 , PXI_Trig7 = 7
}
Output DestinationTerminal More...
enum class | CountDirection { Up = JY5320Import.JY5320_CI_Count_Up , Down = JY5320Import.JY5320_CI_Count_Down , External = JY5320Import.JY5320_CI_Count_External }
Counter direction. More...
enum class | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
CIMode More...
enum class CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | CISampleClockSource { Implicit = JY5320Import.JY5320_CI_ImplicitClock , Internal = JY5320Import.JY5320_CI_InternalClock , External = JY5320Import.JY5320_CI_ExternalClock }
CI Sample Clock Source. More...
enum class | EdgeType { Rising , Falling , Any }
Edge Type More...
enum class | CITimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum class | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity More...
enum class | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type More...
enum class | CITriggerType { Immediate = JY5320Import.JY5320_CIO_Immediately , Digital = JY5320Import.JY5320_CIO_Digital , Soft = JY5320Import.JY5320_CIO_Soft }
TriggerType Digital/Immediate/Soft More...
enum class CIDigitalTriggerSource {
PFI0 = JY5320Import.JY5320_DigitalTriggerSource_PFI_0 , PFI1 = JY5320Import.JY5320_DigitalTriggerSource_PFI_1 , PFI2 = JY5320Import.JY5320_DigitalTriggerSource_PFI_2 , PFI3 = JY5320Import.JY5320_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5320Import.JY5320_DigitalTriggerSource_PFI_4 , PFI5 = JY5320Import.JY5320_DigitalTriggerSource_PFI_5 , PFI6 = JY5320Import.JY5320_DigitalTriggerSource_PFI_6 , PFI7 = JY5320Import.JY5320_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5320Import.JY5320_DigitalTriggerSource_PFI_8 , PFI9 = JY5320Import.JY5320_DigitalTriggerSource_PFI_9 , PFI10 = JY5320Import.JY5320_DigitalTriggerSource_PFI_10 , PFI11 = JY5320Import.JY5320_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5320Import.JY5320_DigitalTriggerSource_PFI_12 , PFI13 = JY5320Import.JY5320_DigitalTriggerSource_PFI_13 , PFI14 = JY5320Import.JY5320_DigitalTriggerSource_PFI_14 , PFI15 = JY5320Import.JY5320_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5320Import.JY5320_AI_StartTrig , AI_ReferenceTrig = JY5320Import.JY5320_AI_ReferenceTrig , CI_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , CI_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig ,
CO_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , CO_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig , CI_0_OutPut = JY5320Import.JY5320_CO_0_Output , CI_1_OutPut = JY5320Import.JY5320_CO_1_Output
}
CI Digital trigger source. More...
enum class | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge More...
enum class InputTerminal {
PFI0 = JY5320Import.JY5320_DigitalTriggerSource_PFI_0 , PFI1 = JY5320Import.JY5320_DigitalTriggerSource_PFI_1 , PFI2 = JY5320Import.JY5320_DigitalTriggerSource_PFI_2 , PFI3 = JY5320Import.JY5320_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5320Import.JY5320_DigitalTriggerSource_PFI_4 , PFI5 = JY5320Import.JY5320_DigitalTriggerSource_PFI_5 , PFI6 = JY5320Import.JY5320_DigitalTriggerSource_PFI_6 , PFI7 = JY5320Import.JY5320_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5320Import.JY5320_DigitalTriggerSource_PFI_8 , PFI9 = JY5320Import.JY5320_DigitalTriggerSource_PFI_9 , PFI10 = JY5320Import.JY5320_DigitalTriggerSource_PFI_10 , PFI11 = JY5320Import.JY5320_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5320Import.JY5320_DigitalTriggerSource_PFI_12 , PFI13 = JY5320Import.JY5320_DigitalTriggerSource_PFI_13 , PFI14 = JY5320Import.JY5320_DigitalTriggerSource_PFI_14 , PFI15 = JY5320Import.JY5320_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7 ,
CI_0_OutPut = JY5320Import.JY5320_CO_0_Output , CI_1_OutPut = JY5320Import.JY5320_CO_1_Output , Timebase_100MHz = JY5320Import.JY5320_CIO_100MHz , Timebase_5MHz = JY5320Import.JY5320_CIO_5MHz ,
Timebase_100kHz = JY5320Import.JY5320_CIO_100kHz
}
enum class IOTerminal {
PFI0 = JY5320Import.JY5320_DigitalTriggerOut_PFI_0 , PFI1 = JY5320Import.JY5320_DigitalTriggerOut_PFI_1 , PFI2 = JY5320Import.JY5320_DigitalTriggerOut_PFI_2 , PFI3 = JY5320Import.JY5320_DigitalTriggerOut_PFI_3 ,
PFI4 = JY5320Import.JY5320_DigitalTriggerOut_PFI_4 , PFI5 = JY5320Import.JY5320_DigitalTriggerOut_PFI_5 , PFI6 = JY5320Import.JY5320_DigitalTriggerOut_PFI_6 , PFI7 = JY5320Import.JY5320_DigitalTriggerOut_PFI_7 ,
PFI8 = JY5320Import.JY5320_DigitalTriggerOut_PFI_8 , PFI9 = JY5320Import.JY5320_DigitalTriggerOut_PFI_9 , PFI10 = JY5320Import.JY5320_DigitalTriggerOut_PFI_10 , PFI11 = JY5320Import.JY5320_DigitalTriggerOut_PFI_11 ,
PFI12 = JY5320Import.JY5320_DigitalTriggerOut_PFI_12 , PFI13 = JY5320Import.JY5320_DigitalTriggerOut_PFI_13 , PFI14 = JY5320Import.JY5320_DigitalTriggerOut_PFI_14 , PFI15 = JY5320Import.JY5320_DigitalTriggerOut_PFI_15 ,
PXI_Trig0 = JY5320Import.JY5320_TriggerOut_PXI_0 , PXI_Trig1 = JY5320Import.JY5320_TriggerOut_PXI_1 , PXI_Trig2 = JY5320Import.JY5320_TriggerOut_PXI_2 , PXI_Trig3 = JY5320Import.JY5320_TriggerOut_PXI_3 ,
PXI_Trig4 = JY5320Import.JY5320_TriggerOut_PXI_4 , PXI_Trig5 = JY5320Import.JY5320_TriggerOut_PXI_5 , PXI_Trig6 = JY5320Import.JY5320_TriggerOut_PXI_6 , PXI_Trig7 = JY5320Import.JY5320_TriggerOut_PXI_7
}
enum class | CISignalExportSource { StartTrig , SampleClock }
SourceSignal More...
enum class | COIdleState { HighLevel = JY5320Import.JY5320_HighLevel , LowLevel = JY5320Import.JY5320_LowLevel }
Idle state when pulse output before start and after stop. More...
enum class | COMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
CO output mode More...
enum class | COTriggerType { Immediate = JY5320Import.JY5320_CIO_Immediately , Digital = JY5320Import.JY5320_CIO_Digital , Soft = JY5320Import.JY5320_CIO_Soft }
TriggerType Digital/Immediate/Soft More...
enum class CODigitalTriggerSource {
PFI0 = JY5320Import.JY5320_DigitalTriggerSource_PFI_0 , PFI1 = JY5320Import.JY5320_DigitalTriggerSource_PFI_1 , PFI2 = JY5320Import.JY5320_DigitalTriggerSource_PFI_2 , PFI3 = JY5320Import.JY5320_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5320Import.JY5320_DigitalTriggerSource_PFI_4 , PFI5 = JY5320Import.JY5320_DigitalTriggerSource_PFI_5 , PFI6 = JY5320Import.JY5320_DigitalTriggerSource_PFI_6 , PFI7 = JY5320Import.JY5320_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5320Import.JY5320_DigitalTriggerSource_PFI_8 , PFI9 = JY5320Import.JY5320_DigitalTriggerSource_PFI_9 , PFI10 = JY5320Import.JY5320_DigitalTriggerSource_PFI_10 , PFI11 = JY5320Import.JY5320_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5320Import.JY5320_DigitalTriggerSource_PFI_12 , PFI13 = JY5320Import.JY5320_DigitalTriggerSource_PFI_13 , PFI14 = JY5320Import.JY5320_DigitalTriggerSource_PFI_14 , PFI15 = JY5320Import.JY5320_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5320Import.JY5320_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5320Import.JY5320_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5320Import.JY5320_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5320Import.JY5320_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5320Import.JY5320_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5320Import.JY5320_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5320Import.JY5320_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5320Import.JY5320_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5320Import.JY5320_AI_StartTrig , AI_ReferenceTrig = JY5320Import.JY5320_AI_ReferenceTrig , CI_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , CI_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig ,
CO_0_StartTrig = JY5320Import.JY5320_CIO0_StartTrig , CO_1_StartTrig = JY5320Import.JY5320_CIO1_StartTrig , CI_0_OutPut = JY5320Import.JY5320_CO_0_Output , CI_1_OutPut = JY5320Import.JY5320_CO_1_Output
}
CO Digital trigger source. More...
enum class | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum class | COSignalExportSource { StartTrig , Output }
SourceSignal More...

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JY5320.AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator

Enumerator
Edge | Edge Comparator
Hysteresis | Hysteresis Comparator
Window | Window Comparator

◆ AIAnalogTriggerEdge

enum JY5320.AIAnalogTriggerEdge
strong

AI Analog Trigger Edge

Enumerator
Rising | Rising
Falling | Falling

◆ AIAnalogTriggerSource

enum JY5320.AIAnalogTriggerSource
strong

AI Analog Trigger Source

Enumerator
Channel_0 | channel 0
Channel_1 | channel 1
Channel_2 | channel 2
Channel_3 | channel 3
Channel_4 | channel 4
Channel_5 | channel 5
Channel_6 | channel 6
Channel_7 | channel 7
Channel_8 | channel 8
Channel_9 | channel 9
Channel_10 | channel 10
Channel_11 | channel 11
Channel_12 | channel 12
Channel_13 | channel 13
Channel_14 | channel 14
Channel_15 | channel 15
Channel_16 | channel 16
Channel_17 | channel 17
Channel_18 | channel 18
Channel_19 | channel 19
Channel_20 | channel 20
Channel_21 | channel 21
Channel_22 | channel 22
Channel_23 | channel 23
Channel_24 | channel 24
Channel_25 | channel 25
Channel_26 | channel 26
Channel_27 | channel 27
Channel_28 | channel 28
Channel_29 | channel 29
Channel_30 | channel 30
Channel_31 | channel 31

◆ AIAnalogWindowCondition

enum JY5320.AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition

Enumerator
Entering | Rising
Leaving | Falling

◆ AIBandWidth

enum JY5320.AIBandWidth
strong

AI BandWidth

Enumerator
_25KHz | 25KHz BandWidth
_220KHz | 220KHz BandWidth

◆ AIDigitalTriggerEdge

enum JY5320.AIDigitalTriggerEdge
strong

AI Digital Trigger Edge

Enumerator
Rising | Rising
Falling | Falling

◆ AIDigitalTriggerSource

enum JY5320.AIDigitalTriggerSource
strong

AI Digital Trigger Source

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
CI_0_StartTrig | CI0_StartTrig
CI_1_StartTrig | CI1_StartTrig
CO_0_StartTrig | CO0_StartTrig
CO_1_StartTrig | CO0_StartTrig
CI_0_OutPut | CI0_StartTrig
CI_1_OutPut | CI1_StartTrig

◆ AIMode

enum JY5320.AIMode
strong

AIMode

Enumerator
Single | 单点模式
Finite | Finite
Continuous | Continuous
Record | Record

◆ AISampleClockSource

enum JY5320.AISampleClockSource
strong

AIClockSource Type

Enumerator
Internal | Internal
External | External //外部时钟采集有问题，暂时禁用，待新固件发布后再开放20200908

◆ AISignalExportSource

enum JY5320.AISignalExportSource
strong

AI Signal Export Source

Enumerator
StartTrig | AI_StartTrig
ReferenceTrig | AI_ReferenceTrig
SampleClock | AI_SampleClock

◆ AITriggerMode

enum JY5320.AITriggerMode
strong

AI Trigger Mode

Enumerator
Start | Start Trigger Mode
Reference | Reference Trigger Mode，Valid when JY5320AITask.Mode is AIMode.Finite

◆ AITriggerType

enum JY5320.AITriggerType
strong

Trigger Type: Digital/Analog/Immediate

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Analog | Analog Trigger
Soft | Soft Trigger

◆ CIDigitalTriggerEdge

enum JY5320.CIDigitalTriggerEdge
strong

CI Digital Trigger Edge

Enumerator
Rising | RisingEdge
Falling | FallingEdge

◆ CIDigitalTriggerSource

enum JY5320.CIDigitalTriggerSource
strong

CI Digital trigger source.

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_StartTrig | AI_StartTrig
AI_ReferenceTrig | AI_ReferenceTrig
CI_0_StartTrig | CI0_StartTrig
CI_1_StartTrig | CI1_StartTrig
CO_0_StartTrig | CO0_StartTrig
CO_1_StartTrig | CO0_StartTrig
CI_0_OutPut | CI0_StartTrig
CI_1_OutPut | CI1_StartTrig

◆ CIMode

enum JY5320.CIMode
strong

CIMode

Enumerator
Single | Single
Finite | Finite
Continuous | Continuous

◆ CISampleClockSource

enum JY5320.CISampleClockSource
strong

CI Sample Clock Source.

Enumerator
Implicit | Implicit
Internal | Internal
External | External

◆ CISignalExportSource

enum JY5320.CISignalExportSource
strong

SourceSignal

Enumerator
StartTrig | CI_StartTrig
SampleClock | CI_SampleClock

◆ CITimebaseSource

enum JY5320.CITimebaseSource
strong

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum JY5320.CITriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ CIType

enum JY5320.CIType
strong

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting
Period | Period Measure
Frequency | Frequenc Measure
Pulse | Pulse Measure
SemiPeriod | SemiPeriod Measure
TwoEdgeSeparation | TwoEdgeSeparation Measure
QuadEncoder | QuadEncoder
TwoPulseEncoder | EncoderTwoPulse

◆ ClockTerminal

enum JY5320.ClockTerminal
strong

External Sample Clock Terminal

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_SampleClock | AI_SampleClock
CI0_SampleClock | AI_SampleClock
CI1_SampleClock | AI_SampleClock
CO0_Output | AI_SampleClock
CO1_Output | AI_SampleClock

◆ CODigitalTriggerEdge

enum JY5320.CODigitalTriggerEdge
strong

CO Digital Trigger Edge

Enumerator
Rising | Rising Edge
Falling | Falling Edge

◆ CODigitalTriggerSource

enum JY5320.CODigitalTriggerSource
strong

CO Digital trigger source.

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_StartTrig | AI_StartTrig
AI_ReferenceTrig | AI_ReferenceTrig
CI_0_StartTrig | CI0_StartTrig
CI_1_StartTrig | CI1_StartTrig
CO_0_StartTrig | CO0_StartTrig
CO_1_StartTrig | CO0_StartTrig
CI_0_OutPut | CI0_StartTrig
CI_1_OutPut | CI1_StartTrig

◆ COIdleState

enum JY5320.COIdleState
strong

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum JY5320.COMode
strong

CO output mode

Enumerator
Single | Single pulse output
Finite | Finite
ContinuousNoWrapping | ContinuousNoWrapping
ContinuousWrapping | ContinuousWrapping

◆ COPulseType

enum JY5320.COPulseType
strong

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum JY5320.COSignalExportSource
strong

SourceSignal

Enumerator
StartTrig | CI_StartTrig
Output | CO_Output

◆ COTimebaseSource

enum JY5320.COTimebaseSource
strong

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum JY5320.COTriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ CountDirection

enum JY5320.CountDirection
strong

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases
Down | Counter decreases
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ EdgeCntOunEvtIdleState

enum JY5320.EdgeCntOunEvtIdleState
strong

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JY5320.EdgeType
strong

Edge Type

Enumerator
Rising | Rising Edge
Falling | Falling Edge
Any | Any Edge

◆ FileFormat

enum JY5320.FileFormat
strong

Streaming file format

Enumerator
Bin

Binary file format

◆ InputTerminal

enum JY5320.InputTerminal
strong

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
CI_0_OutPut | CI0_StartTrig
CI_1_OutPut | CI1_StartTrig
Timebase_100MHz | Timebase_100MHz
Timebase_5MHz | Timebase_5MHz
Timebase_100kHz | Timebase_100kHz

◆ IOTerminal

enum JY5320.IOTerminal
strong

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7

◆ LevelPolarity

enum JY5320.LevelPolarity
strong

Level Polarity

Enumerator
LowLevel | Low level
HighLevel | High level
None | No active polarity.

◆ QuadEncodingType

enum JY5320.QuadEncodingType
strong

Quadrature Encoding Type

Enumerator
X1 | X1
X2 | X2
X4 | X4

◆ RecordMode

enum JY5320.RecordMode
strong

Two stream mode from enum Finite/Infinite

Enumerator
Finite | Finite Streaming
Infinite | InFinite Streaming

◆ SignalExportDestination

enum JY5320.SignalExportDestination
strong

Output DestinationTerminal

Enumerator
PFI0 | PFI0
PFI1 | PFI1
PFI2 | PFI2
PFI3 | PFI3
PFI4 | PFI4
PFI5 | PFI5
PFI6 | PFI6
PFI7 | PFI7
PFI8 | PFI8
PFI9 | PFI9
PFI10 | PFI10
PFI11 | PFI11
PFI12 | PFI12
PFI13 | PFI13
PFI14 | PFI14
PFI15 | PFI15
PXI_Trig0 | PXI_Trig0
PXI_Trig1 | PXI_Trig1
PXI_Trig2 | PXI_Trig2
PXI_Trig3 | PXI_Trig3
PXI_Trig4 | PXI_Trig4
PXI_Trig5 | PXI_Trig5
PXI_Trig6 | PXI_Trig6
PXI_Trig7 | PXI_Trig7

◆ SyncPulseRouting

enum JY5320.SyncPulseRouting
strong

Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port)

Enumerator
NONE | Default NONE
PXI_Trig0 | PXI Trig0
PXI_Trig1 | PXI Trig1
PXI_Trig2 | PXI Trig2
PXI_Trig3 | PXI Trig3
PXI_Trig4 | PXI Trig4
PXI_Trig5 | PXI Trig5
PXI_Trig6 | PXI Trig6
PXI_Trig7 | PXI Trig7

◆ SyncTopology

enum JY5320.SyncTopology
strong

Synchronization board configuration

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum JY5320.SyncTriggerRouting
strong

Master card trigger signal routing (Master card routes trigger signal to this port)

Enumerator
NONE | Default NONE
PXI_Trig0 | PXI Trig0
PXI_Trig1 | PXI Trig1
PXI_Trig2 | PXI Trig2
PXI_Trig3 | PXI Trig3
PXI_Trig4 | PXI Trig4
PXI_Trig5 | PXI Trig5
PXI_Trig6 | PXI Trig6
PXI_Trig7 | PXI Trig7


5320 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY5320
  • AIAnalogTriggerEdge : JY5320
  • AIAnalogTriggerSource : JY5320
  • AIAnalogWindowCondition : JY5320
  • AIBandWidth : JY5320
  • AIDigitalTriggerEdge : JY5320
  • AIDigitalTriggerSource : JY5320
  • AIMode : JY5320
  • AISampleClockSource : JY5320
  • AISignalExportSource : JY5320
  • AITriggerMode : JY5320
  • AITriggerType : JY5320

- c -

  • CIDigitalTriggerEdge : JY5320
  • CIDigitalTriggerSource : JY5320
  • CIMode : JY5320
  • CISampleClockSource : JY5320
  • CISignalExportSource : JY5320
  • CITimebaseSource : JY5320
  • CITriggerType : JY5320
  • CIType : JY5320
  • ClockTerminal : JY5320
  • CODigitalTriggerEdge : JY5320
  • CODigitalTriggerSource : JY5320
  • COIdleState : JY5320
  • COMode : JY5320
  • COPulseType : JY5320
  • COSignalExportSource : JY5320
  • COTimebaseSource : JY5320
  • COTriggerType : JY5320
  • CountDirection : JY5320

- e -

  • EdgeCntOunEvtIdleState : JY5320
  • EdgeType : JY5320

- f -

  • FileFormat : JY5320

- i -

  • InputTerminal : JY5320
  • IOTerminal : JY5320

- l -

  • LevelPolarity : JY5320

- q -

  • QuadEncodingType : JY5320

- r -

  • RecordMode : JY5320

- s -

  • SignalExportDestination : JY5320
  • SyncPulseRouting : JY5320
  • SyncTopology : JY5320
  • SyncTriggerRouting : JY5320


5320 C# Programming Manual: Package Functions

- a -

  • AIAnalogTriggerComparator : JY5320
  • AIAnalogTriggerEdge : JY5320
  • AIAnalogTriggerSource : JY5320
  • AIAnalogWindowCondition : JY5320
  • AIBandWidth : JY5320
  • AIDigitalTriggerEdge : JY5320
  • AIDigitalTriggerSource : JY5320
  • AIMode : JY5320
  • AISampleClockSource : JY5320
  • AISignalExportSource : JY5320
  • AITriggerMode : JY5320
  • AITriggerType : JY5320

- c -

  • CIDigitalTriggerEdge : JY5320
  • CIDigitalTriggerSource : JY5320
  • CIMode : JY5320
  • CISampleClockSource : JY5320
  • CISignalExportSource : JY5320
  • CITimebaseSource : JY5320
  • CITriggerType : JY5320
  • CIType : JY5320
  • ClockTerminal : JY5320
  • CODigitalTriggerEdge : JY5320
  • CODigitalTriggerSource : JY5320
  • COIdleState : JY5320
  • COMode : JY5320
  • COPulseType : JY5320
  • COSignalExportSource : JY5320
  • COTimebaseSource : JY5320
  • COTriggerType : JY5320
  • CountDirection : JY5320

- e -

  • EdgeCntOunEvtIdleState : JY5320
  • EdgeType : JY5320

- f -

  • FileFormat : JY5320

- i -

  • InputTerminal : JY5320
  • IOTerminal : JY5320

- l -

  • LevelPolarity : JY5320

- q -

  • QuadEncodingType : JY5320

- r -

  • RecordMode : JY5320

- s -

  • SignalExportDestination : JY5320
  • SyncPulseRouting : JY5320
  • SyncTopology : JY5320
  • SyncTriggerRouting : JY5320


5320 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JY5320 |
C JY5320AITask | JY5320 Analog Input Task
C AIChannel | AI Channel parameter class
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | AI Trigger class
C AIDigitalTrigger | AI Digital Trigger
C AIAnalogTrigger | AI Analog Trigger
C AIRecord | AI Record class
C AIAdvanced | AI Advance parameter
C DSMode | DS Mode Class Paraments
C AISync | Configure sync signal
C AISignalExport | AI Signal Export Class
C JY5320CITask | JY5320 Counter Input Task
C CISampleClock | CI Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CITimebase |
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C PauseTrigger | Pause trigger configuration class
C FrequencyMeas | Configure CI Measure
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C SemiPeriodMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C CITrigger | Constructor to create an CITrigger task object
C CIDigitalTrigger | CI Digital trigger
C CISignalExport | CI Signal Export Class
C JY5320COTask | JY5320 Counter Output Task
C COTrigger | Constructor to create an COTrigger task object
C CODigitalTrigger | CO Digital trigger
C COPulse | Pulse Parameter
C COExternalTimebase |
C COTimebase |
C COSignalExport | CO Signal Export Class
C JY5320DITask | JY5320DITask Class
C DIChannel | DI Channel parameter class
C JY5320DOTask | JY5320 DOTask
C DOChannel | DOChannel class